Py||Large integer multiplication

Py||Large integer multiplication题目描述AlargeintegerisanintegerthatfarexceedstherangeofintegertypesrepresentedbythePythonlanguage,suchas10tothepowerof100.Pleasecalculatethemultiplyresultoftwolargein…

大家好,又见面了,我是你们的朋友全栈君。如果您正在找激活码,请点击查看最新教程,关注关注公众号 “全栈程序员社区” 获取激活教程,可能之前旧版本教程已经失效.最新Idea2022.1教程亲测有效,一键激活。

Jetbrains全系列IDE使用 1年只要46元 售后保障 童叟无欺

题目描述
A large integer is an integer that far exceeds the range of integer types represented by the Python language, such as 10 to the power of 100. Please calculate the multiply result of two large integers and output the last digit of the result.
输入
The input consists of multiple lines, two large integers m and n per line, with a range of -10^100< m, n <10^100.
输出
Output the last digit of the multiply result of each pair of large integers, then wrap.
样例输入 Copy
1000000000000 1111111111111111111111111111111111
333333333 6565787654309090111
样例输出 Copy
0
3

while True:
    s=[str(i) for i in input().split()]
    s1=[]
    s2=[]
    j=0
    s1=[s[0]]
    s2=[s[1]]
    a=len(s1[0])
    b=len(s2[0])
    j=1
    for i in s1[0]:
        if j==a:
            x=int(i)
        j=j+1
    k=1
    for i in s2[0]:
        if k==b:
            y=int(i)
        k=k+1
    print((x*y)%10)
版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/160081.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)


相关推荐

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号