(hdu step 6.3.5)Card Game Cheater(匹配的最大数:a与b打牌,问b赢a多少次)

(hdu step 6.3.5)Card Game Cheater(匹配的最大数:a与b打牌,问b赢a多少次)

大家好,又见面了,我是全栈君,今天给大家准备了Idea注册码。

称号:

Card Game Cheater

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 103 Accepted Submission(s): 74
 
Problem Description
Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards face down in a row on the table. Adam’s cards are numbered from 1 to k from his left, and Eve’s cards are numbered 1 to k from her right (so Eve’s i:th card is opposite Adam’s i:th card). The cards are turned face up, and points are awarded as follows (for each i ∈ {1, . . . , k}):

If Adam’s i:th card beats Eve’s i:th card, then Adam gets one point.

If Eve’s i:th card beats Adam’s i:th card, then Eve gets one point.

A card with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace.

If the two i:th cards have the same value, then the suit determines who wins: hearts beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit. 

For example, the ten of spades beats the ten of diamonds but not the Jack of clubs. 

This ought to be a game of chance, but lately Eve is winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards Adam has on the table before he turns them face up. Using this information she orders her own cards so that she gets as many points as possible.

Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally. 

 
Input
There will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases.

Each test case starts with a line with a single positive integer k <= 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has not yet placed them on the table). A card is described by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam’s cards are the ten of clubs, the two of hearts, and the Jack of diamonds, that could be described by the line

TC 2H JD

 
Output
For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.

 
Sample Input
3
1
JD
JH
2
5D TC
4C 5H
3
2H 3H 4H
2D 3D 4D

 
Sample Output
1
1
2

 
 
Source
Northwestern Europe 2004
 
Recommend
8600


题目大意:

a和b手上都有n张牌,b的一张牌赢了a的一张牌,b就得一分,问b能得多少分。

例子分析:

输入:

3
1//两个人手中的牌的张数
JD//adams手上的牌
JH//eves手上的牌
2
5D TC
4C 5H

输出:

第二个例子中的输出结果为1.为什么呢。

由于eves手上仅仅有5H比adams手上的5D大。得1分。他手上的4C要比

adams手上的TC要小,不能得分。


题目分析:

              二分图,求最大匹配。需要注意的是。

1、这道题中的匹配规则已经不是“a愿不愿意与b匹配”了。而是,仅仅有在b>a的时候才干匹配

2、这道题中b和a都是字符串。

怎样比較大小呢?先比較第1个字符然后,假设第1个字符相等再比較第2个字符。

3、这道题是用的是邻接表求的最大匹配数。



代码例如以下:

/*
 * e.cpp
 *
 *  Created on: 2015年3月14日
 *      Author: Administrator
 */

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstring>

using namespace std;

const int maxn = 27;

vector<int> map[maxn];
bool useif[maxn];
int link[maxn];

int n;

/**
 * 获取一张牌前缀的索引
 */
int card_pre(char a){
	string pre = "23456789TJQKA";
	int len = pre.length();

	int i;
	for(i = 0 ; i < len ; ++i){
		if(a == pre.at(i)){
			return i;
		}
	}

	return 0;
}

/**
 * 获取一张牌后缀的索引
 */
int card_suf(char a){
	string suf = "CDSH";
	int len = suf.length();
	int i;
	for(i = 0 ; i < len ; ++i){
		if(a == suf.at(i)){
			return i;
		}
	}

	return 0;
}

/**
 * 比較a和b这两张牌哪一张牌比較大
 */
bool isBig(string a,string b){
	int aa = card_pre(a[0]);//获取一张牌的前缀
	int bb = card_pre(b[0]);//获取一张牌的后缀

	if(aa == bb){//假设这两张牌的前缀同样
		return card_suf(a[1]) < card_suf(b[1]);//则比較后缀
	}

	//假设这两张牌的前缀已经不同样则直接比較前缀
	return aa < bb;
}


/**
 * 推断一个节点t是否能找到和她匹配的节点
 */
bool can(int t){
	int i;
	int size = map[t].size();//获取愿意与节点t匹配的结点的数量
	for(i = 0 ; i < size ; ++i){//遍历每个愿意和结点t匹配的结点
		int index = map[t][i];//获取当前愿意和结点t匹配的节点的索引
		if(useif[index] == false){//假设这个节点还没有匹配
			useif[index] = true;//那么将这个节点标记为已经匹配
			//假设这个节点还没有匹配的节点||月这个节点匹配的节点可以找到其它结点与它匹配
			if(link[index] == -1 || can(link[index])){
				link[index] = t;//那么将当前节点匹配的结点设置为t

				return true;//返回true,表示根节点t可以找到与它匹配的节点
			}
		}
	}

	return false;//返回false,表示节点t无法找到与它匹配的结点
}


/**
 * 求醉大匹配数
 *
 */
int max_match(){
	int num = 0;

	int i;
	for(i = 0 ; i < n ; ++i){//遍历每个结点
		memset(useif,false,sizeof(useif));
		if(can(i) == true){
			num++;
		}
	}

	return num;
}


int main(){
	int t;
	scanf("%d",&t);

	string adams[maxn];

	while(t--){
//		int n;//这里千万不要在定义一个局部变量,否则会覆盖全局变量
		scanf("%d",&n);
		int i;

		//初始化变量
		memset(link,-1,sizeof(link));
		for(i = 0 ; i < n ; ++i){
			map[i].clear();
		}

		for(i = 0 ; i < n ; ++i){//初始化adams的牌
			cin >> adams[i];
		}

		string eves;
		/**
		 * 每次读入eves当前的牌,都接着计算它能与adams的那些牌匹配.
		 * 这列的匹配规则已经不是:a愿不愿意 与b匹配了.
		 * 而是仅仅有当b>a的时候,b才干与a匹配
		 * (为什么呢?由于eves要得分,那么他手上的牌就必需要比adams的大)
		 */
		for(i = 0 ; i < n ; ++i){
			cin >> eves;

			int j;
			for(j = 0 ; j < n ; ++j){
				if(isBig(adams[j],eves) == true){
					map[i].push_back(j);
				}
			}
		}

		printf("%d\n",max_match());//计算最大匹配数
	}

	return 0;
}




版权声明:本文博客原创文章,博客,未经同意,不得转载。

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/117559.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)


相关推荐

  • 自动根据汉字生成拼音_拼音分类表

    自动根据汉字生成拼音_拼音分类表pyhz_tabp2h[]={ {L”A”, L”a1″,1,L”阿啊呵腌吖锕”}, {L”A”, L”a2″,2,L”啊呵嗄”}, {L”A”, L”a3″,3,L”啊呵”}, {L”A”, L”a4″,4,L”啊呵”}, {L”A”, L”a5″,5,L”阿啊呵”}, {L”Ai”, L”ai1″,1,L”哀挨埃唉哎捱锿”},

  • C语言游戏 双缓存解决闪屏问题 详细总结[通俗易懂]

    最近,应学校课程要求,要完成一个C语言课程设计。可以是写一个小游戏,或是写管理系统等。所以,准备做一个改版贪吃蛇:消灭小虫虫(瞎起的名字:D)。之前学过Java,所以学C语言也就比较顺利。而在刚学完C语言刚着手准备做C语言的小游戏时,却发现了一个问题——闪屏。(我在网上查找了很多关于双缓存,有关的解答很少,更少能够让一个完全不了解的小白一个明白的解释。下面我想和大家分享我使用…

  • ue4 项目模板_卡牌游戏项目模板

    ue4 项目模板_卡牌游戏项目模板del.jpg(596.79KB,下载次数:1)2019-4-2116:34上传—————————-1.02更新日志前言:hello,这里是由RC为您带来的卡牌游戏demo1.02更新,在本次更新中,对游戏性进行了大量的调整,并修复了众多的BUG,同时更新了2张新的卡牌。并特别感谢辉仔与糯米大瓜同学为卡牌设计提供了美术支持!非常感谢!OK,下面是更新…

  • 产生随机数算法[通俗易懂]

    产生随机数算法[通俗易懂]两个办法帮你解决如何在Java中产生随机数http://cd.qq.com     随机数在日常的应用和开发中经常会见到,比如说某些系统会为用户生成一个最初的初始化密码,这就是一个随机数。如何生成这个随机数,不同的开发工具的方法也不一样。在应用中,Java是应用最为广泛的开发工具之一,如何在Java中产生随机数,也是很多开发者在初学随机数时的一个必修课,在此为读者贡献两个办法帮你

  • 神经网络的若干关键基础理论研究_DLA深度神经网络

    神经网络的若干关键基础理论研究_DLA深度神经网络这是一篇关于神经网络算法设计的几个基本问题的理论分析的专题文章,涉及到比较多的原理推导。文章的主体来自IanGoodfellow的《DeepLearning》;AndrewNg在Coursera的《MachineLearning》课程;周志华老师的《机器学习》MichaelNielson的线上书籍:曹振华老师的《随机数学基础》。本文涉及到的概念和理论,尽可能参考自维基百科,保证所有观点的严密和权威。

  • springcloud项目知识点「建议收藏」

    springcloud项目知识点「建议收藏」springcloud项目知识点

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号