hdu 5063 Operation the Sequence(Bestcoder Round #13)「建议收藏」

hdu 5063 Operation the Sequence(Bestcoder Round #13)

大家好,又见面了,我是全栈君。

Operation the Sequence

                                                                    Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                            Total Submission(s): 158    Accepted Submission(s): 74




Problem Description
You have an array consisting of n integers: 



a1=1,a2=2,a3=3,,an=n
. Then give you m operators, you should process all the operators in order. Each operator is one of four types:

Type1: O 1 call fun1();

Type2: O 2 call fun2();

Type3: O 3 call fun3();

Type4: Q i query current value of a[i], 
this operator will have at most 50.

Global Variables: a[1…n],b[1…n];

fun1() {

index=1;

  for(i=1; i<=n; i +=2) 

    b[index++]=a[i];

  for(i=2; i<=n; i +=2)

    b[index++]=a[i];

  for(i=1; i<=n; ++i)

    a[i]=b[i];

}

fun2() {

  L = 1;R = n;

  while(L<R) {

    Swap(a[L], a[R]); 

    ++L;–R;

  }

}

fun3() {

  for(i=1; i<=n; ++i) 

    a[i]=a[i]*a[i];

}
 


Input
The first line in the input file is an integer 



T(1T20)
, indicating the number of test cases.

The first line of each test case contains two integer 



n(0<n100000)




m(0<m100000)
.

Then m lines follow, each line represent an operator above.
 


Output
For each test case, output the query values, the values may be so large, you just output the values mod 1000000007(1e9+7).
 


Sample Input
   
   
1 3 5 O 1 O 2 Q 1 O 3 Q 1

 


Sample Output
   
   
2 4

 

官方题解
注意到查询次数不超过50次。那么能够从查询位置逆回去操作,就能够发现它在最初序列的位置,再逆回去就可以
求得当前查询的值。对于一组数据复杂度约为O(50*n)。

ps:记两个操作数组a和c,数组a存的是奇偶排序的上一个元素的位置,数组c存的是逆置操作的上一个元素的位置,这样就能够逆回去操作了。


  代码:

//218ms
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=100000+1000;
int a[maxn];//奇偶排序操作
int q[maxn];//存储操作类型,1是奇偶排序。2是逆置
int c[maxn];//逆置
const int mod=1000000007;
int solve(int cur,int x)//找到在刚開始的位置
{
    int ans=x;
    for(int i=cur-1;i>=0;i--)
    {
        if(q[i]==1)
        {
           ans=a[ans];
        }
        else
        {
            ans=c[ans];
        }
    }
    return ans;
}
int main()
{
    int t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
       int index=1;
       for(int i=1; i<=n; i +=2)
       a[index++]=i;
       for(int i=2; i<=n; i +=2)
        a[index++]=i;
       for(int i=1;i<=n;i++)
       c[i]=n+1-i;
        char s[10];
        int p;
        int cur=0;
        int cou=0;
        for(int i=0;i<m;i++)
        {
            scanf("%s%d",s,&p);
            if(s[0]=='O')
            {
                if(p==3)
                cou++;
                else
                q[cur++]=p;
            }
            else
            {
                long long ans=solve(cur,p);

                for(int i=0;i<cou;i++)
                {
                    ans=ans*ans%mod;
                }
                printf("%I64d\n",ans);
            }
        }
    }
    return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/115774.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)


相关推荐

  • flowable 集成mongodb

    flowable 集成mongodb学无止境,活到老学到老,每天都问自己进步了吗?1.背景由于公司每天有至少1500个表单发起,处理待办任务至少7000个,累计历史任务数据已经达到200多w条,时间一长,通过数据库查询已办的任何和我发起的流程巨慢所以我们考虑到这些数据能不能放入ES或者是mongodb中流程中心1.0版本集成的是ES,速度确实非常快,提升查询性能近万倍,但是由于ES是一个全文检索的系统,对我们这些业务数据来说…

  • c#封装动态库_nginx调用so动态库

    c#封装动态库_nginx调用so动态库一直对动态库的封装理解不是很透彻,虽然之前写过一个Demo,不过并没有真正的理解。所以写下来,帮助自己理解下。1、一个程序从源文件编译生成可执行文件的步骤:预编译–> 编译–> 汇编–>链接(1)预编译,即预处理,主要处理在源代码文件中以“#”开始的预编译指令,如宏展开、处理条件编译指令、处理#include指令等。(2)编译过程就是把预处理完的文件进行一系列词法

  • graduation和completion_guides和maven区别

    graduation和completion_guides和maven区别参考:androidgradle依赖:implementation和compile的区别2017年google后,Androidstudio版本更新至3.0,更新中,连带着com.android.tools.build:gradle工具也升级到了3.0.0,在3.0.0中使用了最新的Gralde4.0里程碑版本作为gradle的编译版本,该版本gradle编译速度有所加速,更加……

    2022年10月26日
  • 原 在windows上创建文件名以“.”开头的文件

    原 在windows上创建文件名以“.”开头的文件

    2021年10月20日
  • ANT安装、环境变量配置及验证

    ANT安装、环境变量配置及验证一、安装ant到官方主页http://ant.apache.org下载新版(目前为Ant1.8.1)的ant,得到的是一个apache-ant-1.8.1-bin.zip的压缩包。将其解压到你的硬盘上,例如:C:\apache-ant-1.8.1。二、配置环境变量window中设置ant环境变量:ANT_HOME   C:/apache-ant-1.8.1path    

  • Python快速入门教程【转】「建议收藏」

    Python快速入门教程【转】「建议收藏」第一章Python基础知识1.1介绍1.1.1特点Python是一种面向对象、解释型计算机程序设计语言。语法简洁清晰,强制用空白符作为语句缩进。Python具有丰富和强大的库,又被称为胶

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号