yodgor mirzajonov_jacqueline novogratz

yodgor mirzajonov_jacqueline novogratz1142.MaximalClique(25)题目:Acliqueisasubsetofverticesofanundirectedgraphsuchthateverytwodistinctverticesinthecliqueareadjacent.Amaximalcliqueisacliquethatcannotbee…

大家好,又见面了,我是你们的朋友全栈君。如果您正在找激活码,请点击查看最新教程,关注关注公众号 “全栈程序员社区” 获取激活教程,可能之前旧版本教程已经失效.最新Idea2022.1教程亲测有效,一键激活。

Jetbrains全系列IDE稳定放心使用

1142. Maximal Clique (25)

  • 题目:
    A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

    Now it is your job to judge if a given subset of vertices can form a maximal clique.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives two positive integers Nv (<= 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

    After the graph, there is another positive integer M (<= 100). Then M lines of query follow, each first gives a positive number K (<= Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

    Output Specification:

    For each of the M queries, print in a line “Yes” if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print “Not Maximal”; or if it is not a clique at all, print “Not a Clique”.

    Sample Input:
    8 10
    5 6
    7 8
    6 4
    3 6
    4 5
    2 3
    8 2
    2 7
    5 3
    3 4
    6
    4 5 4 3 6
    3 2 8 7
    2 2 3
    1 1
    3 4 3 6
    3 3 2 1
    Sample Output:
    Yes
    Yes
    Yes
    Yes
    Not Maximal
    Not a Clique

  • 分析:
    该题是个公式题,完全图边和点有关系 a*(a-1)==e*2,不要使用a(a-1)/2,因为int因为精度损失,计算错误。

    1,所以该题记录了边
    2,最后一个测试点超时,cout引起,修改后通过千万别用cout/cin,数据量小的程序超时一半是这个造成

  • code:
#include<iostream>
using namespace std;
int Nv,Ne;
#include<vector>
vector<int>edge;
#include<map>
#include<algorithm>
map<int,int>in;
int g[210];
bool isClique(int *a,int c)
{
    int count=0;
    int tmp=0;
    for(int i=0;i<c;i++)
    {
        for(int j=i+1;j<c;j++)
        {
            int ta=a[i];
            int tb=a[j];
            if(ta==tb)continue;
            else if(ta<tb)tmp=ta*1000+tb;
            else tmp=tb*1000+ta;
            if(in.find(tmp)!=in.end())count++;
            //cout<<in.size()<<endl;
        }
    }
    if(c*(c-1)==2*count)return true;
    else return false;
}
bool isMax(int*a,int c)
{
    int flag[210];
    for(int i=0;i<c;i++)flag[a[i]]=1;
    for(int i=1;i<=Nv;i++)
    {
        if(flag[i]==1)continue;
        a[c]=i;
        if(isClique(a,c+1)==true)return false;
    }
    return true;
}
int main()
{
    freopen("in.txt","r",stdin);
// cin>>Nv>>Ne;
    scanf("%d%d",&Nv,&Ne);
    int a,b;
    int tmp;
    for(int i=0;i<Ne;i++)
    {
        //cin>>a>>b;
        scanf("%d%d",&a,&b);
        g[a]=g[b]=1;
        if(a<b)tmp=a*1000+b;
        else tmp=b*1000+a;
        in[tmp]=1;
    }
    int M,c;
    cin>>M;
    int q[210];
    for(int i=0;i<M;i++)
    {
        //cin>>c;
        scanf("%d",&c);
        for(int j=0;j<c;j++)
        {
            cin>>tmp;
            q[j]=tmp;
        }
        if(isClique(q,c)==true)
        {
            if(isMax(q,c)==true)
            //cout<<"Yes"<<endl;
            printf("Yes\n");
            else 
            //cout<<"Not Maximal"<<endl;
            printf("Not Maximal\n"); 
        }   
        else 
        //cout<<"Not a Clique"<<endl;
        printf("Not a Clique\n");
    }

    return 0;
}
版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/188093.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)


相关推荐

  • Linux软件卸载_linux系统怎么卸载一个软件

    Linux软件卸载_linux系统怎么卸载一个软件1.安装说明configure作用:是源码安装软件时配置环境用的他根据你的配置选项和你的系统情况生成makefile文件为make做准备。最常用的参数:./configure–prefix作用:不指定prefix,则可执行文件默认放在/usr/local/bin,库文件默认放在/usr/local/lib,配置文件默认放在/usr/local/etc。其它的…

  • 前端代码自动生成器「建议收藏」

    前端代码自动生成器「建议收藏」场景1.CodeFun是什么CodeFun是一款UI设计稿智能生成源代码的工具,支持微信小程序端、移动端H5和混合APP,上传Sketch、PSD等形式的设计稿,通过智能化技术一键生成可维护的前端代码.2.学习成本高吗?对于前端工程师来说,几乎没有学习成本。对于用惯了蓝湖/摹客的前端工程师来说,CodeFun使用流程与前者几乎一致:设计师上传完稿件后,工程师打开界面,选择任意需要的UI区域拷贝走想要的代码即可,只是从原来看标注变成了直接拷贝代码。对于设计师来说,完全不需要遵循某些设计规范

  • async的基本用法「建议收藏」

    async的基本用法「建议收藏」1.async函数的基本形式2.async函数的返回值总是一个Promise无论async函数有无await操作,其总是返回一个Promise。1.没有显式return,相当于return

  • PHP进程间通信-信号

    PHP进程间通信-信号

  • C语言学生管理系统源代码「建议收藏」

      新人博主不易,希望看完点赞“`c/***autor:旋尘*time:2020.4.20*/#includeintMenu(){intcheck_number;do{system(“cls”);/运行前清屏,把选择清掉/printf(“\t学生成绩管理系统*\n”);printf(“\t*|1.添加学生信息\n”);printf(“\t|2.显示学生信息\

  • 通信信道带宽为1Gbit/s,端到端时延为10ms。TCP的发送窗口为65535字节。试问: 可能达到的最大吞吐量是多少?信道的利用率是多少?

    通信信道带宽为1Gbit/s,端到端时延为10ms。TCP的发送窗口为65535字节。试问: 可能达到的最大吞吐量是多少?信道的利用率是多少?通信信道带宽为1Gbit/s,端到端时延10ms。TCP的发送窗口为65535字节。试问:一可能达到的最大吞吐量是多少?信道的利用率是多少?由发送时延=数据长度/信道带宽=655358bit/1Gb/s=0.5242810-3s=0.52428ms来回的传播时延=10ms2=20ms总时延=20.52428ms所以每秒可以产生1000/20.52428个窗口最大吞吐量=6553681000/20.52428=25544769bit/s信道利用率=最大吞吐量/信道带宽=25544769bit/s/

    2022年10月11日

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号