校园网网络规划与设计方案_计算机网络校园网设计总结

校园网网络规划与设计方案_计算机网络校园网设计总结以前自己做的网络课程设计,用了思科软件,具体的文件包和word见另外的文章无锡科技职业学院校园网规划方案1需求分析1.1校园网总体概述无锡科技职业学院位于无锡市新吴区新锡路8号,其学习内部划分多个楼层。共有三个局域网站组成一个大型的校园网,分别为宿舍区域,教学区域,以及实训区域。每个部门又有众多人数,总体加起来也有500人。这三个区域又分别由三台路由器组合而成,形成了一个校园网站.1.2校园网络基本要求网络自身的需求受多方面因素影响:①网络的课伸缩性②现有网络所支持的业务③网络

大家好,又见面了,我是你们的朋友全栈君。如果您正在找激活码,请点击查看最新教程,关注关注公众号 “全栈程序员社区” 获取激活教程,可能之前旧版本教程已经失效.最新Idea2022.1教程亲测有效,一键激活。

Jetbrains全系列IDE稳定放心使用

以前自己做的网络课程设计,用了思科软件,具体的文件包和word见我上传的资源

无锡科技职业学院校园网规划方案

1 需求分析

1.1 校园网总体概述

无锡科技职业学院位于无锡市新吴区新锡路8号,其学习内部划分多个楼层。共有三个局域网站组成一个大型的校园网,分别为宿舍区域,教学区域,以及实训区域。每个部门又有众多人数,总体加起来也有500人。这三个区域又分别由三台路由器组合而成,形成了一个校园网站.

1.2 校园网络基本要求

网络自身的需求受多方面因素影响:①网络的课伸缩性②现有网络所支持的业务③网络的管理④网络冗余及灾难恢复和网络安全⑤网络的约束都是基础的网络需求。只有在基础的网络搭建完成后,才能对后期的网络进行相应的网络建设。因此网络规划与设计常常需要在基础的网络搭建成功后才能进行。

2 网络设计原则

2.1 网络需求调研与系统设计的基本原则

从充分调查入手,充分理解用户业务活动和用户信息需求。

在调查、分析的基础上,在充分考虑需求与约束的前提之下,对网络系统组建于信息系统开发的可行性进行充分的验证,避免盲目性。

运用系统的观念,完成网络工程技术方案的规划和设计。

根据工程时间的需求,将网络系统组建的任务按照设计、论证、实施、验收、用户培训、维护的不同阶段进行安排,大型网络系统的建设需要聘请专业的监理公司对项目执行的全过程进行建立。

强调各阶段文档资

料的完整性与规范性。

2.2 网络工程设计总体原则

网络工程建设必须首先明确用户的实际需求,统一规划,分期建设,选择适合的技术,确保网络工程建设的优先性、可用性、可靠性、可扩展性与安全性。因此,网络设计的原则是实用性、开放性、高可靠性、安全性、先进性与可扩展性。

2.1.1开放性: 

系统设计应采用开放技术、开放结构、开放系统组件和开放用户接口,以利于网络的维护、扩展升级及与外界信息的沟通。
安全性:应能在可靠性的前提下,抵挡来自内部和外部的攻击;采用的安全措施有效、可信,能够在多层次上、以多种方式实现安全的控制。

2.1.2可靠性:

系统及网络结构较为复杂,同时在部分子系统中存在较高的技术性,因此必须保证系统的稳定、可靠和安全运行,具有很高的MTBF(平均无故障工作时间)和极低的MTBR(平均无故障率),提高容错设计,支持故障检测和恢复,可管理性强。网络必须是可靠的,包括网元级的可靠性,如引擎、风扇、单板、总计等;以及网络级的可靠性,如路由、交换的汇聚,链路冗余,负载均衡等。网络必须具有足够高的性能,满足业务的需要。具有容错功能,能满足企业所在地环境、气候条件,抗干扰能力强,对网络的设计、选型、安装、调试等各环节进行统一规划和分析,确保系统运行可靠。

2.1.3统一性:

在系统的设计过程中,坚持“三统一”,即统一规划、统一标准、统一出口。

2.1.4先进性:

在系统的选择与开发过程中,既能满足当前网络的应用需求,又可以在将来需要扩展的时候,能方便地扩展,保护目前的所有投资;设计的配置可以灵活变通,以便适应客户的其他要求。

2.1.5经济性:

在充分满足以上要求的前提下,应充分考虑到企业的经济承受能力,尽可能地节约投资,花好每一分钱。着眼于近期目标和长期的发展,选用先进的设备进行最佳性能组合,利用有限的投资构造一个性能最佳的网络系统。

2.1.6实用性:

实用性设计应能满足目前对网络应用的要求,充分实现内部管理、信息化等要求,使网络的整体性能尽快得到充分的发挥,并且便于掌握.

2.1.7标准化:

网络系统应符合IEEE 802.3、IEEE 802.3u、IEEE 802.3z等以太网标准和IEEE 802.1p、IEEE 802.1q、WBM等网络管理标准。

3 设计方案

3.1 网络设备选型

这是本次实验我们用到的服务器,交换机,路由器的类型

校园网网络规划与设计方案_计算机网络校园网设计总结

3.1.1 路由器选择

CISCO 2811是一款多业务路由器,传输速率为10/100Mbps。3.1.2 服务器设备的选择

基本参数

功能参数

其他参数

路由器类型:多业务路由器

防火墙:内置防火墙

产品内存:DRAM:最大760MB,缺省256MB

端口结构:模块化

Qos支持:支持

闪存:最大128MB,缺省64MB

局域网接口:2个

VPN支持:支持

电源电压:AC 100-240V,47-63Hz

其它端口:2个固定USB1.1端口

网络管理:协议Cisco ClickStart,SNMP

电源功率:160W

3.1.2交换机选择

Cisco Catalyst 2950系列智能以太网交换机是一个固定配置、可堆叠的独立设备系列,提供了线速快速以太网和千兆位以太网连接。

3.2 网络方案拓扑设计

校园网网络规划与设计方案_计算机网络校园网设计总结

图  3-4 网络拓扑图

3.3 VLAN划分和IP地址分配

无锡科技职业学院目前具有在校生5000多人,随着学校教学水平的提升,目前,招生人数逐渐增多,IP地址也变得越来越加紧缺,因为设计规模有限.我们通过三个区域不同的技术设计.来实现区域网的连接.

我们将这三个区域分别分为宿舍区域,教学区域,实训区域.

校园网网络规划与设计方案_计算机网络校园网设计总结校园网网络规划与设计方案_计算机网络校园网设计总结校园网网络规划与设计方案_计算机网络校园网设计总结

内部局域网地址:192.168.0.0/16

IP地址

默认网关

说明

交换机对应端口号

VLAN

Vlan名称

192.168.3.1

192.168.3.254

男生宿舍

Fa0/1

10

VLAN 10

192.168.4.1

192.168.4.254

女生宿舍

Fa0/2

20

VLAN 20

192.168.5.1

192.168.5.254

教师楼

Fa0/1

192.168.5.2

192.168.5.254

学生楼

Fa0/2

192.168.0.1

192.168.0.254

机房

Fa0/1

192.168.0.2

192.168.0.254

实验室

Fa0/2

图  3-3-1 VLAN详细划分与地址分配图

服务器名称

IP地址

网关

备注

Web

192.168.1.1

192.168.1.254

浏览器

FTP

192.168.8.1

192.168.8.254

文件传输

DHCP

192.168.0.253

自动分配

DNS

192.168.0.252

域名解析

图  3-3-2 服务器IP地址规划图

注:以上交换机对应端口号只是列举了众多计算机中的一到两台。一个网络当中,有几百个节点,可以将数十个节点划分到一个VLAN中,而不是只划分一两个。

4 网络设计方案设计

我们分别对这三个区域进行vlan间通信-“单臂路由”,配置标准ALC,动态主机DHCP配置.通过这三个功能的实验,然后再把三台路由器链接起来,实现整个校园网的链接

4.1VLAN间通信“单臂路由”

4.1.1宿舍网络的规划

为了让不同VLAN的男生宿舍和女生宿舍相互通信。我们使用了vlan间通信-单臂路由的方案在2950-24交换机上划分VLAN.

校园网网络规划与设计方案_计算机网络校园网设计总结

  1. 按图所示连接好实验拓扑图,并规划相应计算机的IP地址,用直通线将路由器与交换机连接起来,路由器F0/0端口连交换机F0/3端口。
  2. 先对交换机进行VLAN划分,创建VLAN 10和VLAN 20,结合计算机的IP规划,把交换机的F0/1端口划分到VLAN 10中,把交换机的F0/2端口划分到VLAN 20中,配置交换机的F0/3端口为trunk链路端口

4.1.3添加代码

路由器上创建子接口fa0/0.1和fa0/0.2

Router#
Router#enable
Router#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface f0/0.1
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip address 192.168.3.254 255.255.255.0
Router(config-subif)#interface f0/0.2
Router(config-subif)#encapsulation dot1q 20
Router(config-subif)#ip address 192.168.4.254 255.255.255.0
Router(config-subif)#interface f0/0
Router(config-if)#no shutdown

Switch(config-vlan)#
Switch(config-vlan)#exit
Switch(config)#no vlan 20
Switch(config)#no vlan 10
Switch(config)#exit
划分vlan10和20
Switch#enable
Switch#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#name VLAN10
Switch(config-vlan)#vlan 20
Switch(config-vlan)#name VLAN20
Switch(config-vlan)#end
Switch#

Switch#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface range f0/1
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10
Switch(config-if-range)#interface range f0/2
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20
Switch(config-if-range)#end

校园网网络规划与设计方案_计算机网络校园网设计总结
trunk交换机fa-/3

Switch#config t

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#interface f0/3

Switch(config-if)#switchport mode trunk

4.2配置标准ACL

4.7.1教师楼和学生楼的规划

通过配置ALC协议,使得教师楼可以访问FTP服务器,但是学生楼不可以访问FTP服务器

校园网网络规划与设计方案_计算机网络校园网设计总结

4.7.2具体步骤

  1. 在路由器3上配置IP地址和静态路由

Router>enable

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#interface FastEthernet0/0

Router(config-if)#no shutdown

Router(config-if)#ip address 192.168.5.254 255.255.255.0

Router(config-if)#

Router(config-if)#exit

Router(config)#interface FastEthernet0/1

Router(config-if)#ip address 10.0.0.1 255.0.0.0

Router(config-if)#no shutdown

  1. 在路由器4上配置IP地址和静态路由

Router>enable

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#interface FastEthernet0/0

Router(config-if)#ip address 10.0.0.2 255.0.0.0

Router(config-if)#no shutdown

Router(config-if)#

Router(config-if)#exit

Router(config)#interface FastEthernet0/1

Router(config-if)#ip address 192.168.8.254 255.255.255.0

Router(config-if)#no shutdown

  1. 测试教师楼和学生楼到FTP服务器的连通性

校园网网络规划与设计方案_计算机网络校园网设计总结 校园网网络规划与设计方案_计算机网络校园网设计总结

  1. 设置路由器4上的ALC协议

Router>enable

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#access-list 1 deny host 192.168.5.2

Router(config)#access-list 1 permit any

Router(config)#interface f0/1

Router(config-if)#ip access-group 1 out

Router(config-if)#

  1. 再次测试教师楼和学生楼到FTP服务器的连通性

校园网网络规划与设计方案_计算机网络校园网设计总结

校园网网络规划与设计方案_计算机网络校园网设计总结

  1. 查看路由器4的ALC相关信息

校园网网络规划与设计方案_计算机网络校园网设计总结

4.3动态主机DHCP配置

4.4.1实验室和机房规划

   使得实验室与机房可以从路由器设置的DHCP服务器获取到IP地址,并且能够访问外网web服务器,通过开启DHCP,自动获取ip地址,子网掩码默认网关,DNS服务器.

校园网网络规划与设计方案_计算机网络校园网设计总结

4.4.2具体步骤

  1. 按图所示连接好实验拓扑图,并规划相应计算机的IP地址,通过DNS服务器将web服务器的域名解析为ip地址.通过DHCP服务器为局域网中的机房和实验室配置自动配置地址,默认网关等信息
  2. 先分为为web服务器配置相关信息,然后为路由器添加两个fa0/0,fa0/1端口.再配置DNS和DHCP服务器.

校园网网络规划与设计方案_计算机网络校园网设计总结 ​​​​​​​校园网网络规划与设计方案_计算机网络校园网设计总结

 校园网网络规划与设计方案_计算机网络校园网设计总结校园网网络规划与设计方案_计算机网络校园网设计总结

4.5 路由器配置

连接各个区域的三台路由器,路由器1,路由器2,路由器3.为他们分别配置好端口以及静态路由.具体配置如下

4.5.1宿舍区路由器1

端口网关配置

校园网网络规划与设计方案_计算机网络校园网设计总结

静态路由配置

校园网网络规划与设计方案_计算机网络校园网设计总结

4.5.2教学区路由器3

端口网关配置

校园网网络规划与设计方案_计算机网络校园网设计总结校园网网络规划与设计方案_计算机网络校园网设计总结校园网网络规划与设计方案_计算机网络校园网设计总结校园网网络规划与设计方案_计算机网络校园网设计总结

静态路由配置

校园网网络规划与设计方案_计算机网络校园网设计总结

4.5.3实训区路由器2

端口网关配置

校园网网络规划与设计方案_计算机网络校园网设计总结校园网网络规划与设计方案_计算机网络校园网设计总结

 校园网网络规划与设计方案_计算机网络校园网设计总结

静态路由配置

校园网网络规划与设计方案_计算机网络校园网设计总结

4.6 实现结果

4.6.1宿舍区域ping通

实现男生宿舍与女生宿舍之间ping通

校园网网络规划与设计方案_计算机网络校园网设计总结

4.6.2教学区域ping通

实现教师楼ping通FTP服务器,但是学生楼不能ping

校园网网络规划与设计方案_计算机网络校园网设计总结

校园网网络规划与设计方案_计算机网络校园网设计总结

4.6.3实训区域ping通

实现动态配置,自动获取ip地址等,同时可以登录web浏览器

校园网网络规划与设计方案_计算机网络校园网设计总结

校园网网络规划与设计方案_计算机网络校园网设计总结

校园网网络规划与设计方案_计算机网络校园网设计总结

校园网网络规划与设计方案_计算机网络校园网设计总结

4.6.4各区域ping通

实现各区域相互间ping通

校园网网络规划与设计方案_计算机网络校园网设计总结

5 课程设计的总结

本方案是结合这半年来网络实训知识,对无锡科技职业学院的一个校园网络方案,在设计的过程中本文考虑了vlan间的单臂通信、动态配置DHCP,配置VLA协议等一系列综合性内容。

在本次组网过程中,我花费了大量精力以及时间学会了大量Cisco PacketTrancer模拟器的软件操作.同时在计算机网络的仿真实验中,还了解了一系列的理论知识,比如三次握手,划分子网块,生成树协议STP的功能等.同时也对去年上课所学的理论知识更加理解深入.

当然,在本次方案设计中,也遇到了许多难题.经过多次的操作以及上网查询.解决了许多问题.感谢这次网络课设,经常这次学习使我受益匪浅.致谢!

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/185680.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)
blank

相关推荐

  • Android从无知到有知——NO.7

    Android从无知到有知——NO.7

  • xmind 使用教程[通俗易懂]

    1.这是刚刚打开xmind后的界面,在中央有一个中心主题,你可以把它替换成你自己的主题,比如图形推理。2、把光标定位到中心主题上,然后连续按3次Tab键,你会看到上面效果。tab键可以帮助你迅速的建立某个主题的子主题。3、下面你在连续按3次回车键,你就可以看到上面的效果,你可以通过回车键,建立同级主题。4、你自己在试一试,玩一玩者两个键吧!(tab键和enter回车键)5、如何改变主题的分布方式,你还要学习使用“右键”,选择一个主题,然后点击“右键”,你会发现有很多选择。6、选

  • pycharm中运行lua脚本requier sys报错_pycharm怎么安装jupyter

    pycharm中运行lua脚本requier sys报错_pycharm怎么安装jupyterpycharm中运行jupyternotebook,首先需要安装:pipinstlljupyternotebook安装完成后在pycharm中新建一个ipynb文件如下图: 然后输入代码,但运行出现了一个问题:解决方法如下:在cmd中运行jupyternotebook,可以看到url和token弄完之后确实可以运行了,但是如果把cmd关掉之后又不能运…

  • Redis的那些最常见面试问题

    Redis的那些最常见面试问题

  • 大数据,云计算和物联网三者的关系是什么_云计算侧重于数据分析

    大数据,云计算和物联网三者的关系是什么_云计算侧重于数据分析1、云计算为大数据提供了技术基础,大数据为云计算提供用武之地2、物联网是大数据的重要来源,大数据技术为物联网数据分析提供支持3、云计算为物联网提供了海量数据存储能力,物联网为云技术提供了广阔的应用空间…

  • ajax跨域的解决办法_jsonp解决跨域问题

    ajax跨域的解决办法_jsonp解决跨域问题才发送请求,然后执行servlet,servlet给它响应一段js代码回去,它接收到js代码解释并执行,显示效果,它并没有达到局部刷新的效果,我们让它达到局部刷新的效果,我们点击某一个按钮,我们让它局部刷新,显然上面让页面打开的时候加载script标签就不行了,我们可以让他先加载完,点击页面某一个按钮去加载script标签,来达到页面的局部刷新,整个过程跟ajax没有关系。当out.print(“sayHello({\”name\”\”jackson\”})”)重新刷新页面响应成功。……

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号