计算机网络设计——企业网络规划与搭建

计算机网络设计——企业网络规划与搭建目录摘要 一、任务概述 1.1设计目的 1.2项目任务和要求 1.3参考资料 二、开发环境 三、项目需求分析 四、项目设计和实现 4.1总体设计 4.2功能设计 4.3系统实现 五、程序的运行和测试结果 六、设计中的问题及心得 七、附录摘要在科学技术飞速发展的时代,网络互联技术显示出了它蓬勃发展的生命力,它逐渐进入了人们的家居生活,使得当今社会的智能化和网络化越来越来明显。人们对居住环境的要求也随着计算机的普及和信息产业的发展而大大提高,越来越多的人已经离不开网络

大家好,又见面了,我是你们的朋友全栈君。如果您正在找激活码,请点击查看最新教程,关注关注公众号 “全栈程序员社区” 获取激活教程,可能之前旧版本教程已经失效.最新Idea2022.1教程亲测有效,一键激活。

Jetbrains全系列IDE稳定放心使用

目录
摘要
一、任务概述
1.1 设计目的
1.2 项目任务和要求
1.3 参考资料
二、开发环境
三、项目需求分析
四、项目设计和实现
4.1 总体设计
4.2 功能设计
4.3 系统实现
五、程序的运行和测试结果
六、设计中的问题及心得
七、附录

摘要
在科学技术飞速发展的时代,网络互联技术显示出了它蓬勃发展的生命力,它逐渐进入了人们的家居生活,使得当今社会的智能化和网络化越来越来明显。人们对居住环境的要求也随着计算机的普及和信息产业的发展而大大提高,越来越多的人已经离不开网络了,无论是工作、学习还是休闲娱乐,这些都已经和网络息息相关:人们可以足不出户了解世界上每个角落在发生什么,买到自己心仪的物品,可以在通过网络进行视频会议,远程控制完成一些工作任务等,网络给
人们带来了巨大的便利。由于Internet的信息和服务内容不断的扩大,使得用户对网络的需求急剧增加。同时,企业的网络化也会给企业带来新的市场机遇和商业价值。企业的网络系统建设也随着计算机技术、通信技术、控制技术及多媒体技术进步和互相渗透而发展起来。本课设主要致力于蓝天高科技产品研究与制造公司的网络的设计和实现。阐述了企业网络工程的设计和在设计过程中容易遇到的问题,应该重点考虑的问题。在充分了解组网技术的基础上,根据目前企业网络的发展趋势,结合当前智能化企业网络系统的需求分析,设计出一个企业的网络模型,并对模型进行各方面的细化。根据模型图对设备进行适当的选型。使用模拟软件ENSP对设备进行配置,包括IP地址的规划、路由协议的选择以及交换机的配置等。

关键词 网络化 组网技术 IP 地址规划 交换机配置 NAT

一、任务概述
1.1 设计目的
深入理解网络工程的三层层次设计模型,掌握网络拓扑结构设计、网络地址
规划与设计、综合布线设计等技术,可以对各种网络设备进行规划、设计、安装、
连接与设置,掌握大型企业网络设计和组建方法。
1.2 项目任务和要求
网络工程设计三层层次模型,网络拓扑结构,网络地址规划,综合布线,设
备安装、连接、配置,大型网络规划、设计、组建。
1.3 参考资料
(1) 《Computer Networks》,Andrew S. Tanenbaum,机械工业出版社(英文
影印版)。
(2)《计算机网络:自顶向下方法》,James F. Kurose, Keith W. Ross 著,
陈鸣译,机械工业出版社。
(3)《计算机网络实验指导书》,郭雅,电子工业出版社。
(4)《网络工程设计教程:系统集成方法》,陈鸣,机械工业出版社。
(5)《计算机网络设计》,易建勋,人民邮电出版社。
(6)《计算机网络规划与设计》,吴学毅,机械工业出版社。
二、开发环境
1、运行windows系统的pc
2、使用ensp进行网络的搭建与配置
三、项目需求分析
(1)在企业局域网中,要求使用三层架构。在核心层使用三层交换机作为核心交换机,负责核心交换。汇聚层使用两个交换机来汇聚流量,将流量汇入核心层。接入层交换机负责连接设备,提升端口密度。
(2)企业中不同部门要划分vlan,不同接入层交换机上划入不同vlan,具体设计根据具体要求而定。
(3)局域网内部设置dns服务器和http服务器,以便域名解析和外网访问企业官网。核心层之上。
(4)核心层之上,核心路由器负责流量转发以及配置nat和做端口映射。
四、项目设计和实现
4.1 总体设计
核心部分拓扑为三层架构。对于核心层,使用两台三层交换机作为核心交换机,两台核心交换机分别连上路由器,两核心交换机之间使用链路聚合。对于汇聚层,使用两台交换机,两台交换机中每一台都分别于两台核心交换机相连,保证可靠性。对于接入层,暂时使用七台交换机,每台交换机划入一个vlan,负责一个虚拟局域网的连接,其中有一台负责连接企业的服务器群。
4.2 功能设计
(1)交换机上配置mstp。暂定局域网内有vlan1-6、vlan100。设定一个多生成树组中有实例instance1和instance2,将vlan1-3和vlan100划入instance1,将vlan4-6划入instance2。将LSW1定为instance1的根交换机,将LSW2定为instance2的根交换机。
(2)核心交换机做网关,以减轻路由器负担。核心交换机LSW1做vlan1-3和vlan100的网关,LSW2做vlan4-6的网关。同时实现网关的冗余,让LSW2做vlan1-3和vlan100的备份网关,LSW1做vlan4-6的备份网关。
(3)用LSW1实现vlan1-3和vlan100的dhcp功能,用LSW2实现vlan4-6的dhcp功能。
(4)LSW1、LSW2上配置路由,指向AR1.
(5)AR1上配置接口IP,写入到局域网的静态路由,以及到外网的缺省路由。
(6)AR1上配置nat,局域网内所有IP从AR1到外网时都做IP地址转换,转换为公网地址。
(7)LSW1和LSW1上开启telnet服务,认证模式设定为aaa认证,允许来自外网及内网的运维。
(8)AR1上配置端口映射,外网pc可以通过认证的方式对LSW1和LSW2进行运维,也可以访问企业的官网(www.xpu.com)
4.3 系统实现
网络拓扑图
在这里插入图片描述
(1)搭建拓扑如图
(2)规划IP地址。局域网内暂定划分7个vlan,其中vlan1-6作为用户vlan,vlan100作为服务器群的vlan。
IP地址规划:
172.16.1.0/24 vlan1
172.16.2.0/24 vlan2
172.16.3.0/24 vlan3
172.16.4.0/24 vlan4
172.16.5.0/24 vlan5
172.16.6.0/24 vlan6
172.16.100.0/24 vlan100 用于服务器群
172.16.101.0/24 LSW1和路由器之间的网段
172.16.102.0/24 LSW2和路由器之间的网段
202.100.1.0/24 AR1和ISP(运营商路由器)之间的网段
100.1.1.0/24 公网上用于测试的一个网段
交换机上建立vlan,建立虚接口,给各个接口配置相应的IP地址。
(3)各个交换机根据设定配置接口类型,并配置接口允许列表。
(4)LSW1和LSW2上建立多生成树组a,其中建立两个实例instance1和instance2,分别将vlan1-3、vlan100和vlan4-6划入两实例中,instance1的根交换机定为LSW1,instance2的根交换机定为LSW2。分别在各个交换机上配置mstp。
(5)两核心交换机上配置vrrp。
两交换机上配置虚接口以及虚接口的IP地址,具体映射见下表。
LSW1 LSW2 虚拟网关IP
Vlanif1 172.16.1.1 172.16.1.2 172.16.1.100
Vlanif2 172.16.2.1 172.16.2.2 172.16.2.100
Vlanif3 172.16.3.1 172.16.3.2 172.16.3.100
Vlanif4 172.16.4.2 172.16.4.1 172.16.4.100
Vlanif5 172.16.5.2 172.16.5.1 172.16.5.100
Vlanif6 172.16.6.2 172.16.6.1 172.16.6.100

(6)在两核心交换机上开启dhcp服务,建立对应的地址池,并配置相应的网关地址。在虚接口上开启dhcp。
(7)两核心交换机上开启telnet服务,使用aaa认证。
(8)局域网服务器群设置有一个dns服务器和两个http服务器,dns服务器作为各个内网各个网段的默认dns服务器。http服务器供内网和外网访问。
(9)LSW1、LSW2上写入缺省路由,指向AR1。AR1上写入缺省,指向ISP,写入用户网段的静态,指向两核心交换机。
(10)AR1上与ISP相连的接口上配置nat,172.16.0.0/16网段内的地址转换为202.100.1.1。
(11)AR1上配置端口映射,分别将访问202.100.1.10的指定端口转换为访问LSW1和LSW2的23端口以及http服务器。
五、程序的运行和测试结果
1、多生成树配置正常
在这里插入图片描述
在这里插入图片描述

2、内网用户网段可以连接外网网段
在这里插入图片描述

3、内网可以互通
在这里插入图片描述

4、内网可以访问服务器群

在这里插入图片描述

5、路由器冗余可以实现,对于vlan1,正常情况下LSW1作为网关,LSW1出故障时LSW2作为网关。将LSW1的接口关闭之后网关切换到LSW2上,vrrp功能正常。
在这里插入图片描述

6、可正常登录LSW1和LSW2进行运维
在这里插入图片描述

六、设计中的问题及心得
1、配置过程中多生成树的配置出现问题。通过更规范的操作解决问题。
2、静态路由出现问题。路由器上对用户网段的路由汇总与核心交换机上的缺省路由相
遇,产生了环路。通过删除汇总的路由改为对各个用户网段的单个的路由解决问题。
3、端口映射出现问题,内网可以登录核心交换机而外网不能登录。相同的配置在其他
相同的配置在其他拓扑中可以实现相应功能,疑似模拟器的问题。
七、附录
部分核心配置:
1、vlan的建立及交换机接口的配置(以LSW1为例)
[sw1]vlan batch 2 to 6 100
[sw1]int g 0/0/1
[sw1-GigabitEthernet0/0/1]port link-type access
[sw1-GigabitEthernet0/0/1]port default vlan 1000
[sw1]int Eth-Trunk 1
[sw1-Eth-Trunk1]quit
[sw1]int g 0/0/2
[sw1-GigabitEthernet0/0/2]eth-trunk 1 //链路聚合
[sw1-GigabitEthernet0/0/2]int g 0/0/3
[sw1-GigabitEthernet0/0/3]eth-trunk 1
[sw1]int g 0/0/4
[sw1-GigabitEthernet0/0/4]port link-type trunk
[sw1-GigabitEthernet0/0/4]port trunk allow-pass vlan all
[sw1]int g 0/0/5
[sw1-GigabitEthernet0/0/5]port link-type trunk
[sw1-GigabitEthernet0/0/5]port trunk allow-pass vlan all
2、配置mstp(LSW1、LSW2)
[sw1]stp re
[sw1-mst-region]region-name a
[sw1-mst-region]instance 1 vlan 1 to 3 100
[sw1-mst-region]instance 2 vlan 4 to 6
[sw1-mst-region]active region-configuration
[sw1]stp instance 1 root primary
[sw1]stp instance 2 root secondary

[sw2]stp re
[sw2-mst-region]region-name a
[sw2-mst-region]instance 1 vlan 1 to 3 100
[sw2-mst-region]instance 2 vlan 4 to 6
[sw2-mst-region]active region-configuration
[sw2]stp instance 1 root secondary
[sw2]stp instance 2 root primary
3、LSW1、LSW2上配置虚接口,作为各个vlan的网关。配置vrrp。配置dhcp(以LSW1上配置vlanif1和LSW2上配置vlanif2为例)
[sw1]int vlanif 1
[sw1-Vlanif1]ip address 172.16.1.1 24
[sw1-Vlanif1]vrrp vrid 1 virtual-ip 172.16.1.100
[sw1-Vlanif1]vrrp vrid 1 priority 120
[sw1-Vlanif1]vrrp vrid 1 track interface GigabitEthernet 0/0/1 reduced 30
[sw1]dhcp enable
[sw1]ip pool vlan1
[sw1-ip-pool-vlan1]network 172.16.1.0 mask 24
[sw1-ip-pool-vlan1]gateway-list 172.16.1.100
[sw1-ip-pool-vlan1]dns-list 172.16.100.254
[sw1]int vlanif 1
[sw1-Vlanif1]dhcp select global

[sw2]int vlanif 4
[sw2-Vlanif4]ip address 172.16.4.1 24
[sw2-Vlanif4]vrrp vrid 4 virtual-ip 172.16.4.100
[sw2-Vlanif4]vrrp vrid 4 priority 120
[sw2-Vlanif4]vrrp vrid 4 track interface GigabitEthernet 0/0/1 reduced 30
[sw2]dhcp enable
[sw2]ip pool vlan1
[sw2-ip-pool-vlan4]network 172.16.4.0 mask 24
[sw2-ip-pool-vlan4]gateway-list 172.16.4.100
[sw2-ip-pool-vlan4]dns-list 172.16.100.254
[sw2]int vlanif 4
[sw2-Vlanif4]dhcp select global

4、LSW1、LSW2上开启telnet服务
[sw1]aaa
[sw1-aaa]local-user admin1 privilege level 15 password cipher 123
[sw1-aaa]qu
[sw1]user-interface vty 0 4
[sw1-ui-vty0-4]authentication-mode aaa

[sw2]aaa
[sw2-aaa]local-user admin2 privilege level 15 password cipher 123
[sw2-aaa]qu
[sw2]user-interface vty 0 4
[sw2-ui-vty0-4]authentication-mode aaa

5、核心交换机和路由器上配置静态路由
[r1]ip route-static 172.16.1.0 24 172.16.101.2
[r1]ip route-static 172.16.1.0 24 172.16.102.2
[r1]ip route-static 172.16.2.0 24 172.16.101.2
[r1]ip route-static 172.16.2.0 24 172.16.102.2
[r1]ip route-static 172.16.3.0 24 172.16.101.2
[r1]ip route-static 172.16.3.0 24 172.16.102.2
[r1]ip route-static 172.16.4.0 24 172.16.101.2
[r1]ip route-static 172.16.4.0 24 172.16.102.2
[r1]ip route-static 172.16.5.0 24 172.16.101.2
[r1]ip route-static 172.16.5.0 24 172.16.102.2
[r1]ip route-static 172.16.6.0 24 172.16.101.2
[r1]ip route-static 172.16.6.0 24 172.16.102.2
[r1]ip route-static 0.0.0.0 0 202.100.1.2

[sw1]ip route-static 0.0.0.0 0 172.16.101.1
[sw2]ip route-static 0.0.0.0 0 172.16.102.1
5、路由器上配置nat,配置端口映射
[r1]acl 2000
[r1-acl-basic-2000]rule permit source 172.16.0.0 0.0.255.255
[r1-acl-basic-2000]quit
[r1]int g 0/0/1
[r1-GigabitEthernet0/0/1]nat outbound 2000

[r1-GigabitEthernet0/0/1]nat server protocol tcp global 202.100.1.10 23 inside 172.16.1.1 23
[r1-GigabitEthernet0/0/1]nat server protocol tcp global 202.100.1.10 23333 inside 172.16.4.1 23
[r1-GigabitEthernet0/0/1]nat server protocol tcp global 202.100.1.10 80 inside 172.16.100.252 80
[r1-GigabitEthernet0/0/1]nat server protocol tcp global 202.100.1.10 80000 inside 172.16.100.253 80

附上博主在ensp上搭建的topo文件:
提取链接:topo文件
提取码:qfx2

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/185482.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)
blank

相关推荐

  • java怎么输出保留两位小数_剖析Java输出怎么保留两位小数「建议收藏」

    java怎么输出保留两位小数_剖析Java输出怎么保留两位小数「建议收藏」Java中,当两个整数相除时,由于小数点以后的数字会被截断,运算结果将为整数,此时若希望得到运算结果为浮点数,必须将两整数其一或是两者都强制转换为浮点数,也就是Java输出怎么保留两位小数?接下来郑州达内Java培训老师给大家以实例说明:Java怎么取两位小数?题目:项目中有一个小需求,两个整数相除,结果需要保留两位小数,即1.00、0.50这种数据格式。以下做法不行,因为两整数相除,小数点以后的…

  • C++数据结构——队列「建议收藏」

    C++数据结构——队列「建议收藏」C++数据结构——队列参考博客:http://www.cnblogs.com/QG-whz/p/5171123.htmlhttp://www.169it.com/article/2718050585107790752.html1、队列(Queue)与栈一样,是一种线性存储结构,它具有如下特点:(1)队列中的数据元素遵循“先进先出”(FirstInFirstOut)的原则,简称FIFO结构;(…

  • notepad++编译C++

    notepad++编译C++

  • 雅虎优化ETags

    雅虎优化ETagsETags为网页资源的优化又提供了一个便捷的方案。ConfigureETagstag:serverEntitytags(ETags)areamechanismthatwebserversandbrowsersusetodeterminewhetherthecomponentinthebrowser'scachematchest

  • layuiadmin配置mysql_layuiAdmin 后台管理模板

    layuiadmin配置mysql_layuiAdmin 后台管理模板完全由layui自有的前端架构实现而成的一套通用型后台管理模板系统iframe版使用简单基于iframe标签页实现,简单实用传统开发模式,撸起袖子直接开干交互体验相比“单页版”略有点欠缺始终基于全新的layui版本面向全屏幕尺寸的响应式适配能力灵活的主题色配置专属的开发者文档,助你快速掌握版本的持续更新,集大众之所需layui社区VIP标识专属的会员专区,与同道中人隔空交流不限制…

    2022年10月29日
  • Google资深工程师深度讲解Go语言–面向对象(四)[通俗易懂]

    Google资深工程师深度讲解Go语言–面向对象(四)

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号