大家好,又见面了,我是你们的朋友全栈君。如果您正在找激活码,请点击查看最新教程,关注关注公众号 “全栈程序员社区” 获取激活教程,可能之前旧版本教程已经失效.最新Idea2022.1教程亲测有效,一键激活。
Jetbrains全系列IDE稳定放心使用
C语言-链表排序
题目描述
已有a、b两个链表,每个链表中的结点包括学号、成绩。要求把两个链表合并,按学号升序排列。
输入
第一行,a、b两个链表元素的数量N、M,用空格隔开。 接下来N行是a的数据 然后M行是b的数据 每行数据由学号和成绩两部分组成
输出
按照学号升序排列的数据
样例输入
2 3
5 100
6 89
3 82
4 95
2 10
样例输出
2 10
3 82
4 95
5 100
6 89
My first try on Linkedlist, quite hard for me at first
especially the beginning part
also pointer is a hard part for I havn’t understood yet
BUT PRACTICE PAYS
I finally get to know it
#include<cstdio>
#include<cstdlib>
typedef struct student{
//定义结构
int num;
int sco;
struct student *next;
}stu;
stu *creat(int n){
//创建链表
stu *head,*node,*end;
head=(stu*)malloc(sizeof(stu));
end=head;
for(int i=0;i<n;i++){
node=(stu*)malloc(sizeof(stu));
scanf("%d %d",&node->num,&node->sco);
end->next=node;
end=node;
}
end->next=NULL;
return head;
}
stu *link(stu *a,stu*b)//链接
{
stu *p=a;
while(p->next!=NULL){
p=p->next;
}
p->next=b->next;
return a;
}
void linksort(struct student *p){
//排序
int tnum,tsco,k=0,i=1;
struct student *p1;
p1=p;
while(i!=0){
while(p1->next!=NULL){
if(p1->num>p1->next->num) {
tnum=p1->num;
p1->num=p1->next->num;
p1->next->num=tnum;
tsco=p1->sco;
p1->sco=p1->next->sco;
p1->next->sco=tsco;
k++;
}
p1=p1->next;
}
p1=p;
if(k>0){
k=0;
}
else i=0;
}
}
void print(stu *a)//输出
{
stu *p=a;
while(p->next!=NULL){
printf("%d %d\n",p->num,p->sco);
p=p->next;
}
}
int main()
{
int n,m;
scanf("%d %d",&n,&m);
stu *a=creat(n);
stu *b=creat(m);
stu *p=link(a,b);
linksort(p);
print(p);
return 0;
}
发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/183087.html原文链接:https://javaforall.cn
【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛
【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...