1151LCA in a Binary Tree(最近公共祖先LCA)[通俗易懂]

1151LCA in a Binary Tree(最近公共祖先LCA)[通俗易懂]原题链接The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.Given any two nodes in a binary tree, you are supposed to find their LCA.Input Specification:Each input file contains one test

大家好,又见面了,我是你们的朋友全栈君。如果您正在找激活码,请点击查看最新教程,关注关注公众号 “全栈程序员社区” 获取激活教程,可能之前旧版本教程已经失效.最新Idea2022.1教程亲测有效,一键激活。

Jetbrains全系列IDE使用 1年只要46元 售后保障 童叟无欺

原题链接

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:
For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found…

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题解
最近公共祖先

#include<bits/stdc++.h>
#define x first
#define y second
#define send string::npos
#define lowbit(x) (x&(-x))
#define left(x) x<<1
#define right(x) x<<1|1
using namespace std;
typedef long long ll;
typedef pair<int,int> PII;
typedef struct Node * pnode;
const int N = 2e5 + 10;
const int M = 3 * N;
const int INF = 0x3f3f3f3f;
const ll LINF = 0x3f3f3f3f3f3f3f3f;
const int Mod = 1e9;
int in[N],pre[N];
map<int,int>mm;
void lca(int a,int b,int l,int r,int ll,int rr){ 

if(l <= r){ 

int key = pre[l];
int mid = mm[key];
int lsum = mid - ll;
int poxa = mm[a],poxb = mm[b];
// cout<<l<<" "<<r<<" "<<ll<<" "<<rr<<" "<<key<<"-"<<lsum<<endl;
if(a == key)printf("%d is an ancestor of %d.\n",a,b);
else if(b == key)printf("%d is an ancestor of %d.\n",b,a);
else if(poxa < mid && poxb > mid || poxa > mid && poxb < mid)printf("LCA of %d and %d is %d.\n",a,b,key);
else if(poxa < mid && poxb < mid)lca(a,b,l + 1,l + lsum,ll,mid - 1);
else lca(a,b,l + lsum + 1,r,mid + 1,rr);
}
}
int main(){ 

int n,m;
ios::sync_with_stdio(false);
cin>>n>>m;
for(int i = 0;i < m;i ++){ 

cin>>in[i];
mm[in[i]] = i;
}
for(int i = 0;i < m;i ++){ 

cin>>pre[i];
}
int x,y;
for(int i = 0;i < n;i ++)
{ 

cin>>x>>y;
bool flag1 = (mm.find(x) == mm.end() ? false:true);
bool flag2 = (mm.find(y) == mm.end() ? false:true);
if(!flag1 && !flag2)printf("ERROR: %d and %d are not found.\n",x,y);
else if(!flag1)printf("ERROR: %d is not found.\n",x);
else if(!flag2)printf("ERROR: %d is not found.\n",y);
else lca(x,y,0,m-1,0,m-1);
}
return 0;
}
版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/168772.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)


相关推荐

  • Linux终端Web浏览器w3m

    Linux终端Web浏览器w3m

  • Java程序员烂大街了吗?No or yes?

    Java程序员烂大街了吗?No or yes?Java程序员烂大街了吗?当下,越来越多的企业需要程序员,即使不是互联网公司,很普通的公司程序员也是标配。过去程序员属于稀缺岗位,而今随着技术的发展在二三线城市,甚至四线五线城市,小县城都有程序员的需求。作为一个发展越来越成熟的行业,Java程序员越来越多,自然会感觉程序员到处都是。小乐认为,虽然越来越多,也不必过分的担忧。虽然现在学Java做Java的人很多,但不难发现依旧有很多公司在招聘Java程序员。究其原因就是现在Java程序员虽然很多,但是精的很少。简单的增删该查估计一个门外汉网上找个开源

  • 火狐的Http请求插件的安装和使用[通俗易懂]

    火狐的Http请求插件的安装和使用[通俗易懂]火狐有一个http请求插件,安装之后就可以用它来测试各种http请求了(GET/POST/PUT/DELETE)。安装步骤如下:1、打开火狐的附加组件管理器2、在左边菜单栏选择插件3、在搜索栏搜索httpRequest4、选择并安装,然后重启浏览器5、以上步骤完成后,在浏览器右上角就已经出现该插件了6、点击它即可打开,然后就可以模拟http请求了…

  • 做一个电商网站需要多少钱

    做一个电商网站需要多少钱做一个电商网站详细成本一、域名费用:有些的顶级域名非常贵,但如果需要搭建一个好的商城,那么域名也要最好的,因此,域名的成本非常高。

  • set a date for_setcallback

    set a date for_setcallbacksetTimeout只在指定时间后执行一次functionhello(){alert(“hello”);}//使用方法名字执行方法vart1=window.setTimeout(hello,1000);vart2=window.setTimeout(“hello()”,3000);//使用字符串执行方法window.clearTimeout(t1);//去掉定时器setTimeInterval//实时刷新时间单位为毫秒setInterv

  • Xshell安装docker「建议收藏」

    Xshell安装docker「建议收藏」docker基本组成镜像(image):docker镜像好比一个模板,可以通过这个模板创建容器服务,例如:tomcat镜像===>run===>tomcat01容器(提供服务器)通过这个镜像可以创建多个容器(最终服务或项目在容器中运行)容器(container):docker利用容器技术,独立运行一个或一组应用,通过镜像来创建。启动、停止、删除基本命令目前就可以把这个容器理解为就是一个简易的linux系统仓库(repository):存放镜像的地方,类似maven中央仓库仓库

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号