大家好,又见面了,我是你们的朋友全栈君。
uva 11151 Longest Palindrome
A palindrome is a string that reads the same from the left as it does from the right. For example, I, GAG and MADAM are palindromes, but ADAM is not. Here, we consider also the empty string as a palindrome.
From any non-palindromic string, you can always take away some letters, and get a palindromic subsequence. For example, given the string ADAM, you remove the letter M and get a palindrome ADA.
Write a program to determine the length of the longest palindrome you can get from a string.
Input and Output
The first line of input contains an integer T (≤ 60). Each of the next T lines is a string, whose length is always less than 1000.
For ≥90% of the test cases, string length ≤ 255.
For each input string, your program should print the length of the longest palindrome you can get by removing zero or more characters from it.
Sample Input
2
ADAM
MADAM
Sample Output
3
5
题目大意:求给出的字符串中最长的回文串。
解题思路:字符串的正序和逆序求最长公共子序列。
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
using namespace std;
typedef long long ll;
char s[1005], s2[1005];
int dp[1005][1005], len;
void DP() {
memset(dp, 0, sizeof(dp));
for (int i = 1; i <= len; i++) {
for (int j = 1; j <= len; j++) {
if (s[i - 1] == s2[j - 1]) {
dp[i][j] = dp[i - 1][j - 1] + 1;
} else {
dp[i][j] = max(dp[i - 1][j], dp[i][j - 1]);
}
}
}
}
int main() {
int T;
scanf("%d%*c", &T);
while (T--) {
gets(s);
len = strlen(s);
for (int i = len - 1; i >= 0; i--) {
s2[i] = s[len - i - 1];
}
DP();
printf("%d\n", dp[len][len]);
}
return 0;
}
发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/157216.html原文链接:https://javaforall.cn
【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛
【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...