大家好,又见面了,我是你们的朋友全栈君。
顽强的小白
1146 Topological Order (25 分)
This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:
Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.
Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4
题目解析
判断所给的序列是不是拓扑排序
我的思路很暴力,拓扑排序本来就是一个一个拿掉图上的顶点,这些被拿掉的顶点只有一个要求,就是不能有其他顶点指向它,因此我的思路就是,判断当点要拿掉的结点有没有被谁指着,如果有就不是拓扑排序。
代码实现
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn=1005;
bool vis[maxn];
int G[maxn][maxn];
vector<int> ans;int main(){
fill(G[0],G[0]+maxn*maxn,0);
int n,e,u,v;
scanf("%d%d",&n,&e);
for(int i=0;i<e;++i){
scanf("%d%d",&u,&v);
G[u][v]=1;
}
int m;
scanf("%d",&m);
for(int i=0;i<m;++i){
fill(vis,vis+n+1,true); //初始状态 灯全亮
int flag=0;
for(int j=0;j<n;++j){
scanf("%d",&u);
for(int k=1;k<=n;++k){
if(vis[k]==true&&G[k][u]==1){
flag=1;
break;
}
}
vis[u]=false; //把这个顶点灭灯
}
if(flag==1) ans.push_back(i);
}
for(int i=0;i<ans.size();++i) {
printf("%d",ans[i]);
if(i<ans.size()-1) printf(" ");
else printf("\n");
}
}
发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/133288.html原文链接:https://javaforall.cn
【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛
【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...