PAT日志 1146「建议收藏」

PAT日志 1146「建议收藏」顽强的小白1146TopologicalOrder(25分)ThisisaproblemgivenintheGraduateEntranceExamin2018:WhichofthefollowingisNOTatopologicalorderobtainedfromthegivendirectedgraph?Nowyouare…

大家好,又见面了,我是你们的朋友全栈君。

顽强的小白

1146 Topological Order (25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

题目解析

判断所给的序列是不是拓扑排序
我的思路很暴力,拓扑排序本来就是一个一个拿掉图上的顶点,这些被拿掉的顶点只有一个要求,就是不能有其他顶点指向它,因此我的思路就是,判断当点要拿掉的结点有没有被谁指着,如果有就不是拓扑排序。

代码实现

#include <cstdio> 
#include <vector> 
#include <algorithm> 
using namespace std; 
const int maxn=1005;
bool vis[maxn];
int G[maxn][maxn];
vector<int> ans;int main(){ 

fill(G[0],G[0]+maxn*maxn,0);
int n,e,u,v;
scanf("%d%d",&n,&e);
for(int i=0;i<e;++i){ 

scanf("%d%d",&u,&v);
G[u][v]=1;
}
int m;
scanf("%d",&m);
for(int i=0;i<m;++i){ 

fill(vis,vis+n+1,true); //初始状态 灯全亮 
int flag=0;
for(int j=0;j<n;++j){ 

scanf("%d",&u);
for(int k=1;k<=n;++k){ 

if(vis[k]==true&&G[k][u]==1){ 

flag=1;
break; 
}
}
vis[u]=false;   //把这个顶点灭灯 
}
if(flag==1) ans.push_back(i);
}
for(int i=0;i<ans.size();++i) { 

printf("%d",ans[i]);
if(i<ans.size()-1) printf(" ");
else printf("\n");
}
} 
版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/133288.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)
blank

相关推荐

  • HTML iframe 标签[通俗易懂]

    HTML iframe 标签[通俗易懂]定义和用法iframe元素会创建包含另外一个文档的内联框架(即行内框架)把需要的文本放置在和之间,这样就可以应对无法理解iframe的浏IFrame对象IFrame对象代表一个HTML的内联框架在HTML文档中每出现一次,一个IFrame对象就会被创建。属性frameborder=1或0规定是否显示边框height=pixels或%…

    2022年10月28日
  • 命令查看Win10等详细激活信息的方法

    命令查看Win10等详细激活信息的方法命令查看Win10等详细激活信息方法:1、slmgr全称:SoftwareLicenseManager2、VBS是基于VisualBasic的脚本语言。VBS的全称是:MicrosoftVisualBasicScriptEdition。(微软公司可视化BASIC脚本版)。Win+R输入:1、slmgr.vbs-dlv显示:最为详尽…

  • ttl电平与rs232电平转换电路(232电平定义)

    1RS232接口简介RS232接口又称DB9接口,是现在主流的串行通信接口之一。由于RS232接口标准出现较早,难免有不足之处,主要有以下四点:1)接口的信号电平值较高,易损坏接口电路的芯片,又因为与TTL电平不兼容故需使用电平转换电路方能与TTL电路连接。 2)传输速率较低,在异步传输时,波特率为20Kbps;3)接口使用一根信号线和一根信号返回线而构成共地的传输形

  • VBA基础知识整理[通俗易懂]

    VBA基础知识整理[通俗易懂]最近由于项目的需要,需要在Excel自定义一些函数,来完成特殊的处理,为了完成工作,就囫囵吞枣的写了一些代码,现在闲暇下来,就好好的学习一下,VBA的基础知识。1.变量1.Dim<>As<>2.规则变量名称必须使用一个字母作为第一个字符。变量名称不能使用空格,句点(.),感叹号(

  • WebStorm快捷键配置「建议收藏」

    WebStorm快捷键配置「建议收藏」①浏览器快捷键设置

  • python jieba库_Python jieba库的使用说明「建议收藏」

    python jieba库_Python jieba库的使用说明「建议收藏」1、jieba库基本介绍(1)、jieba库概述jieba是优秀的中文分词第三方库-中文文本需要通过分词获得单个的词语-jieba是优秀的中文分词第三方库,需要额外安装-jieba库提供三种分词模式,最简单只需掌握一个函数(2)、jieba分词的原理Jieba分词依靠中文词库-利用一个中文词库,确定汉字之间的关联概率-汉字间概率大的组成词组,形成分词结果-除了分词,用户还可以添加自定义…

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号