每天一道算法_5_Financial Management「建议收藏」

今天的题目更简单,在考虑是不是应该有挑选性的选题目做。题目是Financial Management,如下: DescriptionLarry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has

大家好,又见面了,我是全栈君。

今天的题目没法更简单了,在考虑是不是应该有挑选性的选题目做。

题目是Financial Management,如下:

 

Description

Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what’s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

Input

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

Sample Input

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

Sample Output

$1581.42

 

代码如下:

import java.math.BigDecimal;
import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;


public class FinancialManagement {
	public static void main(String args[]){
		Scanner in = new Scanner(System.in);
		List<Float> list = new ArrayList<Float>();
		int all = 12;
		while(all > 0){
			float f = Float.valueOf(in.nextLine());
			list.add(f);
			all --;
		}
		float sum = 0;
		for(int i = 0; i < list.size(); i ++){
			sum += list.get(i);
		}
		float average = sum/12;
		BigDecimal b = new BigDecimal(average);
		average = b.setScale(2, BigDecimal.ROUND_HALF_UP).floatValue();
		System.out.println("$"+average);
	}
}

 

作者:jason0539

微博:http://weibo.com/2553717707

博客:http://blog.csdn.net/jason0539(转载请说明出处)

 

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/121385.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)


相关推荐

  • java集合底层实现原理_java数据存入数组

    java集合底层实现原理_java数据存入数组modCount:记录当前集合被修改的次数在所有的集合实现类中(Collection与Map中),都会有一个 modCount 的变量出现,它的作用就是记录当前集合被修改的次数。下面以ArrayList 类进行说明:添加方法:删除方法:可以看出,两个操作都会影响元素的个数。 当我们使用迭代器或 foreach 遍历时,如果你在 foreach 遍历时,自动调用迭代器的迭代方法,此时在遍历过程中调用了集合的add,remove方法时,modCount就会改变,而迭代器记录的modCount

  • mac goland 2021激活码(最新序列号破解)[通俗易懂]

    mac goland 2021激活码(最新序列号破解),https://javaforall.cn/100143.html。详细ieda激活码不妨到全栈程序员必看教程网一起来了解一下吧!

  • Redis端口为什么是6379?

    Redis端口为什么是6379?先介绍下redis的作者SalvatoreSanfilippo(Antirez),意大利人,就是下图这位。Antirez现在已经40多岁了,依然奋斗在代码一线,为开源社区做贡献。Antirez出生在非英语系国家,所以英语一直是他的短板。他曾经写过一篇博文,《英语伤痛15年》,以自己的实际经历鼓励非英语系国家的程序员突破英语障碍。或说回来,在他的另一篇博文《Redisasan…

  • VMware实现Android x86 8.1 从安装到使用———全网最全,全网首发,本人实测

    VMware实现Android x86 8.1 从安装到使用———全网最全,全网首发,本人实测VMware实现Androidx868.1从安装到使用虚拟机虚拟机Android安装托坑指南一些终端模拟器的指令

  • MySQL常用命令总结

    MySQL常用命令总结一.连接MySQL格式:mysql-h主机地址-u用户名-p用户密码或者:mysql-u用户名-p//回车后要求输入密码,密码不可见1、连接到本机上的MYSQL首先打开DOS窗口,然后进入目录mysql\bin,再键入命令mysql-uroot-p,回车后提示你输密码.注意用户名前可以有空格也可以没有空格,但是如果-p后带有用

  • 黑马程序员—wpf学习笔记四—banding的那些事

    黑马程序员—wpf学习笔记四—banding的那些事——-WindowsPhone7手机开发、.Net培训、期待与您交流!——-一、WPF中,对控件做数据banding,可以方便的进行赋值和获得值的操作:例如一:<Grid><SliderName=”Slider1″HorizontalAlignment=”Left”Margi…

    2022年10月13日

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号