POJ 1509 Glass Beads

POJ 1509 Glass Beads

大家好,又见面了,我是全栈君,祝每个程序员都可以多学几门语言。

后缀自己主动机的简单运用….

Glass Beads
Time Limit: 3000MS   Memory Limit: 10000K
Total Submissions: 2352   Accepted: 1375

Description

Once upon a time there was a famous actress. As you may expect, she played mostly Antique Comedies most of all. All the people loved her. But she was not interested in the crowds. Her big hobby were beads of any kind. Many bead makers were working for her and they manufactured new necklaces and bracelets every day. One day she called her main Inspector of Bead Makers (IBM) and told him she wanted a very long and special necklace. 

The necklace should be made of glass beads of different sizes connected to each other but without any thread running through the beads, so that means the beads can be disconnected at any point. The actress chose the succession of beads she wants to have and the IBM promised to make the necklace. But then he realized a problem. The joint between two neighbouring beads is not very robust so it is possible that the necklace will get torn by its own weight. The situation becomes even worse when the necklace is disjoined. Moreover, the point of disconnection is very important. If there are small beads at the beginning, the possibility of tearing is much higher than if there were large beads. IBM wants to test the robustness of a necklace so he needs a program that will be able to determine the worst possible point of disjoining the beads. 

The description of the necklace is a string A = a1a2 … am specifying sizes of the particular beads, where the last character am is considered to precede character a1 in circular fashion. 

The disjoint point i is said to be worse than the disjoint point j if and only if the string aiai+1 … ana1 … ai-1 is lexicografically smaller than the string ajaj+1 … ana1 … aj-1. String a1a2 … an is lexicografically smaller than the string b1b2 … bn if and only if there exists an integer i, i <= n, so that aj=bj, for each j, 1 <= j < i and ai < bi

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line containing necklace description. Maximal length of each description is 10000 characters. Each bead is represented by a lower-case character of the english alphabet (a–z), where a < b … z.

Output

For each case, print exactly one line containing only one integer — number of the bead which is the first at the worst possible disjoining, i.e.\ such i, that the string A[i] is lexicographically smallest among all the n possible disjoinings of a necklace. If there are more than one solution, print the one with the lowest i.

Sample Input

4
helloworld
amandamanda
dontcallmebfu
aaabaaa

Sample Output

10
11
6
5

Source

[Submit]   [Go Back]   [Status]   [Discuss]

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int CHAR=26,maxn=50000;

struct SAM_Node
{
    SAM_Node *fa,*next[CHAR];
    int len,id,pos;
    SAM_Node(){}
    SAM_Node(int _len)
    {
        fa=0; len=_len;
        memset(next,0,sizeof(next));
    }
};

SAM_Node SAM_node[maxn],*SAM_root,*SAM_last;
int SAM_size;

SAM_Node *newSAM_Node(int len)
{
    SAM_node[SAM_size]=SAM_Node(len);
    SAM_node[SAM_size].id=SAM_size;
    return &SAM_node[SAM_size++];
}

SAM_Node *newSAM_Node(SAM_Node *p)
{
    SAM_node[SAM_size]=*p;
    SAM_node[SAM_size].id=SAM_size;
    return &SAM_node[SAM_size++];
}

void SAM_init()
{
    SAM_size=0;
    SAM_root=SAM_last=newSAM_Node(0);
    SAM_node[0].pos=0;
}

void SAM_add(int x,int len)
{
    SAM_Node *p=SAM_last,*np=newSAM_Node(p->len+1);
    np->pos=len; SAM_last=np;
    for(;p&&!p->next[x];p=p->fa) p->next[x]=np;
    if(!p)
    {
        np->fa=SAM_root; return ;
    }
    SAM_Node *q=p->next[x];
    if(p->len+1==q->len)
    {
        np->fa=q; return;
    }
    SAM_Node *nq=newSAM_Node(q);
    nq->len=p->len+1;
    q->fa=nq; np->fa=nq;
    for(;p&&p->next[x]==q;p=p->fa)
        p->next[x]=nq;
}

void SAM_build(char * s)
{
    SAM_init();
    int len=strlen(s);
    for(int i=0;i<len;i++)
        SAM_add(s[i]-'a',i+1);
}

char str[maxn];
int the_last=-1;

void dfs(SAM_Node* head,int n)
{
    if(n==0)
    {
        the_last=head->pos;
        return ;
    }
    for(int i=0;i<26;i++)
    {
        if(head->next[i])
        {
            dfs(head->next[i],n-1);
            return ;
        }
    }
}

int main()
{
    int T_T;
    scanf("%d",&T_T);
    while(T_T--)
    {
        scanf("%s",str);
        int n=strlen(str);
        for(int i=0;i<n;i++)
            str[i+n]=str[i];
        str[2*n]=0;
        SAM_build(str);
        SAM_Node *temp=SAM_root;
        n=strlen(str);
        dfs(temp,n/2);
        printf("%d\n",the_last+1-n/2);
    }
    return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/118888.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)


相关推荐

  • jconsole 连接 eclipse启动项

    jconsole 连接 eclipse启动项

  • 字符串转list

    字符串转list用特殊符号分割的字符串如何转为List例如:Stringids=“11,32,33”;1、ids转为List2、ids转为List1、List<String>strList=Arrays.asList(ids.split(“,”));“2、List<Long>mediaIdList=Arrays.stream(ids.split(“,”)).map(v->Long.parseLong(v)).collect(Collectors.toLis

  • Java学习之IDEA调试快捷键

    Java学习之IDEA调试快捷键1、F7单步调试,进入函数内部2、F8单步调试,不进入函数内部3、Shift+F7选择要进入的函数4、Shift+F8跳出函数5、Alt+F9运行到

    2021年12月12日
  • 用c语言编写学生成绩管理系统(c语言学生成绩管理系统删除)

    一、课程设计题目①基本要求题目:矩阵乘法。②综合训练:学生成绩管理系统二、设计要求矩阵乘法:编写一个函数实现矩阵A(2行3列)与矩阵B相乘(3行2列),乘积放在C数组中。在主函数中输入相乘的两数组,并输出结果。学生成绩管理:(结构体数组、函数、指针、算法、流程结构及文件等的综合应用)程序说明:有N个学生,每个学生的数据包含学号(不重复)、姓名、三门课的成绩及平均成绩,试设计一学生成绩管理系统,…

  • S3C2440移植uboot之编译烧写uboot

    S3C2440移植uboot之编译烧写uboot移植环境主机:VMWare–ubuntu16.04开发板:S3C24402440编译器:arm-linux-gcc-4.3.2.tgzu-boot:u-boot-2012.04.01.tar.bz2获取uboot进入https://www.denx.de/wiki/U-Boot下载uboot一直往下拉选择如下将下载好的压缩包解压到任意文件夹,并创建sourceinsig…

  • 一种并行随机梯度下降法是什么_随机梯度下降法

    一种并行随机梯度下降法是什么_随机梯度下降法MartinA.Zinkevich等人(Yahoo!Lab)合作的论文ParallelizedStochasticGradientDescent中给出了一种适合于MapReduce的并行随机梯度下降法,并给出了相应的收敛性分析。这里忽略理论部分,根据自己的理解给出文中所提并行随机梯度下降法的描述。

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号