POJ 1322 Chocolate

POJ 1322 Chocolate

大家好,又见面了,我是全栈君,祝每个程序员都可以多学几门语言。

Chocolate
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 8245   Accepted: 2186   Special Judge

Description

In 2100, ACM chocolate will be one of the favorite foods in the world.
 

“Green, orange, brown, red…”, colorful sugar-coated shell maybe is the most attractive feature of ACM chocolate. How many colors have you ever seen? Nowadays, it’s said that the ACM chooses from a palette of twenty-four colors to paint their delicious candy bits.
 

One day, Sandy played a game on a big package of ACM chocolates which contains five colors (green, orange, brown, red and yellow). Each time he took one chocolate from the package and placed it on the table. If there were two chocolates of the same color on the table, he ate both of them. He found a quite interesting thing that in most of the time there were always 2 or 3 chocolates on the table.
 

Now, here comes the problem, if there are C colors of ACM chocolates in the package (colors are distributed evenly), after N chocolates are taken from the package, what’s the probability that there is exactly M chocolates on the table? Would you please write a program to figure it out?
 

Input

The input file for this problem contains several test cases, one per line.
 

For each case, there are three non-negative integers: C (C <= 100), N and M (N, M <= 1000000).
 

The input is terminated by a line containing a single zero.
 

Output

The output should be one real number per line, shows the probability for each case, round to three decimal places.

Sample Input

5 100 2

0

Sample Output

0.625 

Source

 

题意:C种颜色的巧克力在桶中,从里面依次拿出n个巧克力,颜色同样的吃掉,求最后剩下m个巧克力的概率

当n>1000 时候,考虑奇偶性取1000或1001就可以,由于非常大的时候概率会趋于稳定,至于奇数时取1001 偶数

时取1000有些不解

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstdio>
#define N 1010
using namespace std;
double dp[N][110];
int main()
{
    int c,n,m;
    while(scanf("%d",&c)!=EOF)
    {
        if(c==0)
        {
            break;
        }
        scanf("%d %d",&n,&m);
        if(m>c||m>n||(n-m)%2)
        {
            printf("0.000\n");
            continue;
        }
        if(n>1000)
        {
            n = 1000+n%2;
        }
        memset(dp,0,sizeof(dp));
        dp[0][0] = 1;
        dp[1][1] = 1;
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<=i&&j<=c;j++)
            {
                if(j-1>=0)
                {
                    dp[i][j] = dp[i-1][j-1]*(double)(c-j+1)/(double)c;
                }
                dp[i][j] += dp[i-1][j+1]*(double)(j+1)/(double)c;
            }
        }
        printf("%.3lf\n",dp[n][m]);
    }
    return 0;
}

 

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/118765.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)


相关推荐

  • Java中char,short,int,long占几个字节和多少位[通俗易懂]

    Java中char,short,int,long占几个字节和多少位[通俗易懂]1.字节:byte:用来计量存储容量的一种计量单位;位:bit2.一个字节等于8位1byte=8bitchar占用的是2个字节16位,所以一个char类型的可以存储一个汉字。整型:byte:1个字节8位-128~127short:2个字节16位int:4个字节32位long:8个字节64位浮点型:float:4个字节32位doub……

  • opengl 透视投影矩阵_matlab投影函数

    opengl 透视投影矩阵_matlab投影函数图形学惯例下的平行投影矩阵推导首先,确定我们使用以下惯例:将视图坐标系中的顶点Pe变换到NDC坐标系中的顶点Pn。视图坐标系使用右手坐标系,NDC也使用右手坐标系。NDC范围为-1<=x<=1,-1<=y<=1,-1<=z<=1NDC和屏幕的对应关系为:x=1的点在屏幕右边,x=-1在左边;y=1在顶部,y=-1在底部;z=1的点距…

  • 安卓drawable图片路径_安卓drawable添加图片

    安卓drawable图片路径_安卓drawable添加图片Android图片放对应的drawable文件夹

  • 转录组fpkm是什么意思_fpkm值越大表达量

    转录组fpkm是什么意思_fpkm值越大表达量在转录组测序(RNA-Seq)中,基因的表达量是我们关注的重点。基因表达量的衡量指标有:RPKM、FPKM、TPM。RPKM:ReadsPerKilobaseMillion;说实话,这个英文说

  • 调用网站第三方接口实现短信发邮件「建议收藏」

    调用网站第三方接口实现短信发邮件「建议收藏」一,电子邮件的使用在项目开发中,经常会用到通过程序发送电子邮件,例如:注册用户邮件激活,通过邮件找回密码,发送报表等。二,通过PHP程序来操作电子邮件几种通过PHP发送电子邮件的方式1)通过mail()函数发送邮件2)使用fsockopen方式连接smtp服务器发送3)使用phpmailer邮件类发送。个人推荐使用phpmailer邮件类发送,phpmailer比较方便而且功能强大…

  • 生产计划管理软件有哪些?哪个好用_智能生产计划管理

    生产计划管理软件有哪些?哪个好用_智能生产计划管理生产计划管理软件有哪些?哪个好?生产计划管理,一般是指企业对生产活动的计划、组织和控制工作。生产计划管理软件可提高生产效率、提升品质、降低成本等。对企业管理意义深远。​生产计划管理软件介绍:MES制造执行系统​MES系统是一套面向制造企业车间执行层的生产信息化管理系统。是生产工业常见的生产管理软件,他可以为企业提供包括制造数据管理、计划生产调度管理、库存管理以及质量管理,同时还有人力资源管理…

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号