hdu2377Bus Pass(构建更复杂的图+spfa)

hdu2377Bus Pass(构建更复杂的图+spfa)

大家好,又见面了,我是全栈君,今天给大家准备了Idea注册码。

主题链接:

思路:

题目是给了非常多个车站。然后要你找到一个社区距离这些车站的最大值最小。。所以对每一个车站做一次spfa。那么就得到了到每一个社区的最大值,最后对每一个社区扫描一次,得到那个最小值的社区。。

还有题目要求是要最小的id,所以排一次序。

题目:

Bus Pass

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 667    Accepted Submission(s): 271




Problem Description
You travel a lot by bus and the costs of all the seperate tickets are starting to add up. 

Therefore you want to see if it might be advantageous for you to buy a bus pass. 

The way the bus system works in your country (and also in the Netherlands) is as follows: 

when you buy a bus pass, you have to indicate a center zone and a star value. You are allowed to travel freely in any zone which has a distance to your center zone which is less than your star value. For example, if you have a star value of one, you can only travel in your center zone. If you have a star value of two, you can also travel in all adjacent zones, et cetera. 

You have a list of all bus trips you frequently make, and would like to determine the minimum star value you need to make all these trips using your buss pass. But this is not always an easy task. For example look at the following figure: 


hdu2377Bus Pass(构建更复杂的图+spfa)

Here you want to be able to travel from A to B and from B to D. The best center zone is 7400, for which you only need a star value of 4. Note that you do not even visit this zone on your trips! 

 


Input
On the first line an integert(1 <=t<= 100): the number of test cases. Then for each test case: 

One line with two integersnz(2 <=nz<= 9 999) andnr(1 <=nr<= 10): the number of zones and the number of bus trips, respectively. 

nz lines starting with two integers id
i (1 <= id
i <= 9 999) and mz
i (1 <= mz
i <= 10), a number identifying the i-th zone and the number of zones adjacent to it, followed by mz
i integers: the numbers of the adjacent zones. 

nr lines starting with one integer mr
i (1 <= mr
i <= 20), indicating the number of zones the ith bus trip visits, followed by mr
i integers: the numbers of the zones through which the bus passes in the order in which they are visited. 

All zones are connected, either directly or via other zones. 

 


Output
For each test case: 

One line with two integers, the minimum star value and the id of a center zone which achieves this minimum star value. If there are multiple possibilities, choose the zone with the lowest number. 

 


Sample Input
   
   
1 17 2 7400 6 7401 7402 7403 7404 7405 7406 7401 6 7412 7402 7400 7406 7410 7411 7402 5 7412 7403 7400 7401 7411 7403 6 7413 7414 7404 7400 7402 7412 7404 5 7403 7414 7415 7405 7400 7405 6 7404 7415 7407 7408 7406 7400 7406 7 7400 7405 7407 7408 7409 7410 7401 7407 4 7408 7406 7405 7415 7408 4 7409 7406 7405 7407 7409 3 7410 7406 7408 7410 4 7411 7401 7406 7409 7411 5 7416 7412 7402 7401 7410 7412 6 7416 7411 7401 7402 7403 7413 7413 3 7412 7403 7414 7414 3 7413 7403 7404 7415 3 7404 7405 7407 7416 2 7411 7412 5 7409 7408 7407 7405 7415 6 7415 7404 7414 7413 7412 7416

 


Sample Output
   
   
4 7400

 


Source


Recommend

代码为:

#include<cstdio>
#include<queue>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<vector>
#define INF 0x3f3f3f3f
using namespace std;

const int maxn=9999+10;
int dis[maxn],id[maxn],max_dis[maxn];
bool vis[maxn];
vector<int>vec[maxn];
int t,n,bus,cal;

bool cmp(int a,int b)
{
    return a<b;
}

void spfa(int st)
{
    queue<int>Q;
    while(!Q.empty())  Q.pop();
    memset(vis,false,sizeof(vis));
    memset(dis,INF,sizeof(dis));
    Q.push(st);
    dis[st]=0;
    vis[st]=true;
    while(!Q.empty())
    {
        int temp=Q.front();
        Q.pop();
        vis[temp]=false;
        for(int i=0;i<vec[temp].size();i++)
        {
            if(dis[temp]+1<dis[vec[temp][i]])
            {
                dis[vec[temp][i]]=dis[temp]+1;
                if(!vis[vec[temp][i]])
                {
                  vis[vec[temp][i]]=true;
                  Q.push(vec[temp][i]);
                }
            }
        }
    }
}

void read_graph()
{
    memset(max_dis,0,sizeof(max_dis));
    int u;
    scanf("%d%d",&n,&bus);
    for(int i=1;i<=maxn;i++)
        vec[i].clear();
    for(int i=1;i<=n;i++)
    {
        scanf("%d%d",&id[i],&cal);
        for(int j=1;j<=cal;j++)
        {
            scanf("%d",&u);
            vec[id[i]].push_back(u);
        }
    }
    while(bus--)
    {
        scanf("%d",&cal);
        while(cal--)
        {
            int st;
            scanf("%d",&st);
            spfa(st);
            for(int i=1;i<=n;i++)
            {
                if(dis[id[i]]>max_dis[id[i]])
                    max_dis[id[i]]=dis[id[i]];
            }
        }
    }
    int ans=999999999,ans_id;
    sort(id+1,id+1+n,cmp);
    for(int i=1;i<=n;i++)
    {
        if(max_dis[id[i]]<ans)
        {
            ans=max_dis[id[i]];
            ans_id=id[i];
        }
    }
    printf("%d %d\n",ans+1,ans_id);
}


int main()
{
    scanf("%d",&t);
    while(t--)
    {
        read_graph();
    }
    return 0;
}

版权声明:本文博客原创文章。博客,未经同意,不得转载。

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/117648.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)


相关推荐

  • strip 命令的使用方法

    strip 命令的使用方法

  • C ReadProcessMemory

    C ReadProcessMemoryReadProcessMemory函数用于读取其他进程的数据。BOOLSTDCALLReadProcessMemory( HANDLE hProcess, LPCVOID lpBaseAddress, LPVOID lpBuffer, DWORD nSize, LPDWORD lpNumberOfBytesRead ){ NTSTATUSStatus…

  • js保留两位小数四舍五入_parsefloat保留两位小数

    js保留两位小数四舍五入_parsefloat保留两位小数一、我们首先从经典的“四舍五入”算法讲起1、四舍五入的情况 1 2 varnum=2.446242342; num=num.toFixed(2);//输出结果为2.45 2、不四舍五入第一种,先把小数边整数: 1 Math.floor(15.7784514000*100)/100//输出结果为15.77 第二种,当作字符串,使用正则匹配: 1

  • FindWindow和FindWindowEx「建议收藏」

    FindWindow和FindWindowEx「建议收藏」函数型:HWNDFindWindow(LPCTSTRIpClassName,LPCTSTRIpWindowName);IpClassName:指向一个指定了类名的空结束字符串或一个标识类名字符串的成员的指针。如果该参数为一个成员,则它必须为前次调用theGlobaIAddAtom函数产生的全局成员。该成员为16位,必须位于lpClassName的低16位,高位必须为0。如果为NULL,

  • executescalar mysql_ExecuteScalar()

    executescalar mysql_ExecuteScalar()ExecuteScalar()方法的作用是:执行查询,并返回查询所返回的结果集中第一行的第一列。所有其他的列和行将被忽略。它的返回值时object,若是想判断某条数据在数据库里存不存在便可使用该方法,//sql文privatestringm_str_variationInfo=@”SELECTvariationinfoMngnoFROMsellersandvariationmngtbl…

  • ElasticSearch教程(三)————ElasticSearch集群搭建

    ElasticSearch教程(三)————ElasticSearch集群搭建这篇博文我们亲自搭建一个简单的ElasticSearch集群。配置ElasticSearch集群异常的简单,简单到甚至只需要修改两个地方:保证集群名一致和保证集群的中节点端口不重复。

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号