hdu2377Bus Pass(构建更复杂的图+spfa)

hdu2377Bus Pass(构建更复杂的图+spfa)

大家好,又见面了,我是全栈君,今天给大家准备了Idea注册码。

主题链接:

思路:

题目是给了非常多个车站。然后要你找到一个社区距离这些车站的最大值最小。。所以对每一个车站做一次spfa。那么就得到了到每一个社区的最大值,最后对每一个社区扫描一次,得到那个最小值的社区。。

还有题目要求是要最小的id,所以排一次序。

题目:

Bus Pass

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 667    Accepted Submission(s): 271




Problem Description
You travel a lot by bus and the costs of all the seperate tickets are starting to add up. 

Therefore you want to see if it might be advantageous for you to buy a bus pass. 

The way the bus system works in your country (and also in the Netherlands) is as follows: 

when you buy a bus pass, you have to indicate a center zone and a star value. You are allowed to travel freely in any zone which has a distance to your center zone which is less than your star value. For example, if you have a star value of one, you can only travel in your center zone. If you have a star value of two, you can also travel in all adjacent zones, et cetera. 

You have a list of all bus trips you frequently make, and would like to determine the minimum star value you need to make all these trips using your buss pass. But this is not always an easy task. For example look at the following figure: 


hdu2377Bus Pass(构建更复杂的图+spfa)

Here you want to be able to travel from A to B and from B to D. The best center zone is 7400, for which you only need a star value of 4. Note that you do not even visit this zone on your trips! 

 


Input
On the first line an integert(1 <=t<= 100): the number of test cases. Then for each test case: 

One line with two integersnz(2 <=nz<= 9 999) andnr(1 <=nr<= 10): the number of zones and the number of bus trips, respectively. 

nz lines starting with two integers id
i (1 <= id
i <= 9 999) and mz
i (1 <= mz
i <= 10), a number identifying the i-th zone and the number of zones adjacent to it, followed by mz
i integers: the numbers of the adjacent zones. 

nr lines starting with one integer mr
i (1 <= mr
i <= 20), indicating the number of zones the ith bus trip visits, followed by mr
i integers: the numbers of the zones through which the bus passes in the order in which they are visited. 

All zones are connected, either directly or via other zones. 

 


Output
For each test case: 

One line with two integers, the minimum star value and the id of a center zone which achieves this minimum star value. If there are multiple possibilities, choose the zone with the lowest number. 

 


Sample Input
   
   
1 17 2 7400 6 7401 7402 7403 7404 7405 7406 7401 6 7412 7402 7400 7406 7410 7411 7402 5 7412 7403 7400 7401 7411 7403 6 7413 7414 7404 7400 7402 7412 7404 5 7403 7414 7415 7405 7400 7405 6 7404 7415 7407 7408 7406 7400 7406 7 7400 7405 7407 7408 7409 7410 7401 7407 4 7408 7406 7405 7415 7408 4 7409 7406 7405 7407 7409 3 7410 7406 7408 7410 4 7411 7401 7406 7409 7411 5 7416 7412 7402 7401 7410 7412 6 7416 7411 7401 7402 7403 7413 7413 3 7412 7403 7414 7414 3 7413 7403 7404 7415 3 7404 7405 7407 7416 2 7411 7412 5 7409 7408 7407 7405 7415 6 7415 7404 7414 7413 7412 7416

 


Sample Output
   
   
4 7400

 


Source


Recommend

代码为:

#include<cstdio>
#include<queue>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<vector>
#define INF 0x3f3f3f3f
using namespace std;

const int maxn=9999+10;
int dis[maxn],id[maxn],max_dis[maxn];
bool vis[maxn];
vector<int>vec[maxn];
int t,n,bus,cal;

bool cmp(int a,int b)
{
    return a<b;
}

void spfa(int st)
{
    queue<int>Q;
    while(!Q.empty())  Q.pop();
    memset(vis,false,sizeof(vis));
    memset(dis,INF,sizeof(dis));
    Q.push(st);
    dis[st]=0;
    vis[st]=true;
    while(!Q.empty())
    {
        int temp=Q.front();
        Q.pop();
        vis[temp]=false;
        for(int i=0;i<vec[temp].size();i++)
        {
            if(dis[temp]+1<dis[vec[temp][i]])
            {
                dis[vec[temp][i]]=dis[temp]+1;
                if(!vis[vec[temp][i]])
                {
                  vis[vec[temp][i]]=true;
                  Q.push(vec[temp][i]);
                }
            }
        }
    }
}

void read_graph()
{
    memset(max_dis,0,sizeof(max_dis));
    int u;
    scanf("%d%d",&n,&bus);
    for(int i=1;i<=maxn;i++)
        vec[i].clear();
    for(int i=1;i<=n;i++)
    {
        scanf("%d%d",&id[i],&cal);
        for(int j=1;j<=cal;j++)
        {
            scanf("%d",&u);
            vec[id[i]].push_back(u);
        }
    }
    while(bus--)
    {
        scanf("%d",&cal);
        while(cal--)
        {
            int st;
            scanf("%d",&st);
            spfa(st);
            for(int i=1;i<=n;i++)
            {
                if(dis[id[i]]>max_dis[id[i]])
                    max_dis[id[i]]=dis[id[i]];
            }
        }
    }
    int ans=999999999,ans_id;
    sort(id+1,id+1+n,cmp);
    for(int i=1;i<=n;i++)
    {
        if(max_dis[id[i]]<ans)
        {
            ans=max_dis[id[i]];
            ans_id=id[i];
        }
    }
    printf("%d %d\n",ans+1,ans_id);
}


int main()
{
    scanf("%d",&t);
    while(t--)
    {
        read_graph();
    }
    return 0;
}

版权声明:本文博客原创文章。博客,未经同意,不得转载。

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/117648.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)
blank

相关推荐

  • Google搜索解析规则-更准确的使用谷歌搜索引擎获取到自己想要的内容

    Google搜索解析规则-更准确的使用谷歌搜索引擎获取到自己想要的内容如果票选近二十年最伟大的发明,我相信搜索引擎肯定会占据一个不容小觑的位置,它不单是一项发明,更是一项成就,最大程度消灭了信息的不平等。既然人人都可以接触到海量的信息,那么衡量信息财富多寡就只剩下技巧这惟一的标准了:善用搜索引擎的都是信息时代的富翁,不懂搜索引擎的都是信息时代的负翁。而像程序员这种必须终生学习的职业,搜索引擎就是我们的左膀右臂。懂搜索引擎就是我们的基本功,不,应该是童子功。只

  • SpringBoot笔记(五)Linux系统与项目部署

    SpringBoot笔记(五)Linux系统与项目部署Linux操作系统与项目部署**注意:**本版块会涉及到操作系统相关知识。现在,几乎所有智能设备都有一个自己的操作系统,比如我们的家用个人电脑,基本都是预装Windows操作系统,我们的手机也有Android和iOS操作系统,还有程序员比较青睐的MacBook,预装MacOS操作系统,甚至连Macbook的Touchbar都有一个自己的小型操作系统。操作系统是管理计算机硬件与软件资源的计算机程序,操作系统可以对计算机系统的各项资源板块开展调度工作,运用计算机操作系统可以减少人工资源分配的工作强度。.

  • python实现——ASCII谢尔宾斯基地毯

    python实现——ASCII谢尔宾斯基地毯目录一、题目内容:二、思路:三、python代码:4、总结一、题目内容:二、思路:看到这个图案,肯定是自相似的,所以肯定用递归解决这个问题。但是具体怎样的呢?(1)这个其实就是二维矩阵,所以是要判断每个位置是不是要填给定字符,如果确定了每个位置填或不填,那不就解决问题了嘛;(2)用两个for循环不就遍历了所有的位置了么,所以这个也简单,现在的难点在于如何知道每个位置要填,所以用一个函数判断;(3)这个判断的函数需要三个参数,一个是边长数,另外两个是坐标。边界条件是n=1就返回T.

  • Canny边缘检测

    Canny边缘检测Canny边缘检测是一种非常流行的边缘检测算法,是JohnCanny在1986年提出的。它是一个多阶段的算法,即由多个步骤构成。1.图像降噪2.计算图像梯度3.非极大值抑制4.阈值筛选我们就事后诸葛亮,分析下这个步骤的缘由。首先,图像降噪。我们知道梯度算子可以用于增强图像,本质上是通过增强边缘轮廓来实现的,也就是说是可以检测到边缘的。但是,它们受噪声的影响都很大。那么,我…

  • webservice 实例 创建与 调用「建议收藏」

    webservice 实例 创建与 调用「建议收藏」webservice实例创建与调用序webservice选型配置代码webservice接口层接口实现实体webservice挂靠配置启动服务测试服务测试:测试地址客户端生成环境配置代码生成序对接SAP系统,指定要用webservice做对接。不然打死也不用webservice,感觉webService也实现不怎么流行了,过程中遇到了不少问题。就javawebservice而言,框架就有不下十种。网上的教程更是五花八门,零零碎碎,并且很多误导。本博将记录下项目里用的webservi

  • Visifire Chart相关属性详解「建议收藏」

    Visifire Chart相关属性详解「建议收藏」<vc:Chartx:Name=”HourlyChart”Theme=”Theme1″Grid.Row=”1″xmlns:vc=”clr-namespace:Visifire.Charts;assembly=SLVisifire.Charts”Margin=”5″AnimatedUpdate=”true”IndicatorEnabled=”True”Zoomi…

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号