Poj3414广泛搜索

Poj3414广泛搜索

大家好,又见面了,我是全栈君,今天给大家准备了Idea注册码。

<span style="color:#330099;">/*
D - D
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit
 
Status
 
Practice
 
POJ 3414
Description
You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

FILL(i)        fill the pot i (1 ≤ i ≤ 2) from the tap;
DROP(i)      empty the pot i to the drain;
POUR(i,j)    pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).
Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input
On the first and only line are the numbers A, B, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output
The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input
3 5 4
Sample Output
6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)
By Grant Yuan
2014.7.14
poj 3414
广搜
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
bool flag=0;
int next[6]={0,1,2,3,4,5};
int a,b,c;
int aa,bb,cc;
typedef struct{
  int a;
  int b;
  int f;
  int sum;
  int ope;
}node;
int res;
node q[10000];
bool mark[101][101];
int top,base;
int top1;
int s[10000];
bool can(int x1,int y1)
{
    if(x1>=0&&x1<=aa&&y1>=0&&y1<=bb&&mark[x1][y1]==0)
      return 1;
    return 0;
}

void slove()
{   int a1,b1,f1,a2,b2;
    while(top>=base){//cout<<"zhang"<<endl;
     if(q[base].a==cc||q[base].b==cc){
          flag=1;
           res=q[base].sum;
           break;
          }
      for(int i=0;i<6;i++){
          if(i==0)
            {  a1=aa;
               b1=q[base].b;
               if(can(a1,b1)){
                q[++top].a=a1;
                q[top].b=b1;
                q[top].f=base;
                q[top].sum=q[base].sum+1;
                q[top].ope=i;
                mark[a1][b1]=1;}

            }
            else if(i==1)
            {
               a1=q[base].a;
               b1=bb;
               if(can(a1,b1)){
                q[++top].a=a1;
                q[top].b=b1;
                q[top].f=base;
                q[top].sum=q[base].sum+1;
                q[top].ope=i;
                mark[a1][b1]=1;}
            }
            else if(i==2)//1dao2
            {  int m,n;
               m=q[base].a;
               n=bb-q[base].b;
               if(m>=n){
                   a1=m-n;
                   b1=bb;
                if(can(a1,b1)){
                q[++top].a=a1;
                q[top].b=b1;
                q[top].f=base;
                q[top].sum=q[base].sum+1;
                q[top].ope=i;
                mark[a1][b1]=1;} }
                else{
                  a1=0;
                  b1=m+q[base].b;
                  if(can(a1,b1)){
                q[++top].a=a1;
                q[top].b=b1;
                q[top].f=base;
                q[top].sum=q[base].sum+1;
                q[top].ope=i;
                mark[a1][b1]=1;}
                  }}
            else if(i==3)//1dao2
            {  int m,n;
               m=aa-q[base].a;
               n=q[base].b;
               if(n>=m){
                   a1=aa;
                   b1=n-m;
                if(can(a1,b1)){
                q[++top].a=a1;
                q[top].b=b1;
                q[top].f=base;
                q[top].sum=q[base].sum+1;
                q[top].ope=i;
                mark[a1][b1]=1;} }
                else{
                  b1=0;
                  a1=n+q[base].a;
                  if(can(a1,b1)){
                q[++top].a=a1;
                q[top].b=b1;
                q[top].f=base;
                q[top].sum=q[base].sum+1;
                q[top].ope=i;
                mark[a1][b1]=1;}
                  }}
               else if(i==4)
               {
                   a1=0;
                   b1=q[base].b;
                   if(can(a1,b1)){
                    q[++top].a=a1;
                    q[top].b=b1;
                    q[top].f=base;
                    q[top].sum=q[base].sum+1;
                     q[top].ope=i;
                     mark[a1][b1]=1;
                    }}
                else if(i==5)
               {
                   b1=0;
                   a1=q[base].a;
                   if(can(a1,b1)){
                    q[++top].a=a1;
                    q[top].b=b1;
                    q[top].f=base;
                    q[top].sum=q[base].sum+1;
                    q[top].ope=i;
                     mark[a1][b1]=1;
                    }
               }

        }
        base++;
}}
void print()
{   top1=-1;
    int i=base,j;
    while(1){
        s[++top1]=q[i].ope;
        j=q[i].f;
        i=j;
        if(i==0)
          break;
          }
    for(j=top1;j>=0;j--)
    {
        if(s[j]==0)
           cout<<"FILL(1)"<<endl;
        else
          if(s[j]==1)
           cout<<"FILL(2)"<<endl;
        else
           if(s[j]==2)
            cout<<"POUR(1,2)"<<endl;
        else
          if(s[j]==3)
            cout<<"POUR(2,1)"<<endl;
        else
          if(s[j]==4)
            cout<<"DROP(1)"<<endl;
        else
          if(s[j]==5)
            cout<<"DROP(2)"<<endl;
    }
}
int main()
{
    cin>>aa>>bb>>cc;
    top=-1;
    memset(mark,0,sizeof(mark));
    mark[0][0]=1;
    base=0;
    q[++top].a=0;
    q[top].b=0;
    q[top].f=0;
    q[top].sum=0;
    q[top].ope=0;
    slove();
    if(flag==0) cout<<"impossible"<<endl;
    else{cout<<res<<endl;
    print();}
    return 0;

}
</span>

版权声明:本文博客原创文章。博客,未经同意,不得转载。

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/117579.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)


相关推荐

  • mysql != 索引_Mysql语法

    mysql != 索引_Mysql语法转:https://www.cnblogs.com/huanzi-qch/p/15238604.html介绍通常情况下,全文检索引擎我们一般会用ES组件(传送门:SpringBoot系列——ElasticSearch),但不是所有业务都有那么大的数据量、那么大的并发要求,MySQL5.7之后内置了ngram分词器,支持中文分词,使用全文索引,即可实现对中文语义分词检索MySQL支持全文索引和搜索:  MySQL中的全文索引是FULLTEXT类型的索引。  全文索引只能用于InnoDB或My

  • 万能乘法速算法大全_小学数学指算法、加法、减法、乘法、除法简便运算方法大全,收藏…[通俗易懂]

    万能乘法速算法大全_小学数学指算法、加法、减法、乘法、除法简便运算方法大全,收藏…[通俗易懂]在小学数学的学习过程中,计算能力不过关的孩子,数学成绩普遍来说都不算特别理想。很多家长都在反映说,孩子数学成绩非常糟糕,其实很大的一个原因就是因为计算能力不过关。计算能力不仅对于孩子数学成绩的影响非常的大,对于其他各科的影响也是非常的大,可以毫不夸张的说,计算能力不过关的孩子,学习成绩都不是十分理想。根据我在一线教育从事了十几年的经验来说,很多其实都有他们的共同点,我发现孩子在学习数学的过程中遇到…

  • Azure编程笔记(1):序列化复杂类型的TableEntity字段

    Azure编程笔记(1):序列化复杂类型的TableEntity字段

    2021年11月15日
  • 为什么投屏找不到设备(投屏电视显示无法访问服务器)

    现在液晶电视价格越来越便宜,很少的钱就可以买一台60寸以上的电视,那么使用电脑的朋友一定想要把画面投屏到电视上,用于玩游戏、看电影吧!Win10就有非常好用的投屏功能,很多朋友可能不知道如何操作,这里小编和大家分享下具体步骤:Win10投屏电视步骤如下:(以小米电视为例)1、首先将电脑连接无线WIFI。2、将电视也连接在同一个无线WIFI网络下。3、进入电视应用中,选择“无线显示”功能。(不同的型…

  • 前端学习——JQuery Ajax使用经验

    前端学习——JQuery Ajax使用经验

  • ug图改变颜色_unity改变image透明度

    ug图改变颜色_unity改变image透明度UGUI图片将其他颜色去除,显示灰色图片本例适用于UGUI一般项目中会有一些图标,当你拥有该图标显示为彩色图标,一般项目中最占资源的就是图片,不允许添加一张彩色图片,一张灰色图片,必须通过一些方法将彩色图标的颜色去掉,获取图标的灰色值。UGUI自带了一个Shader,Sprites/Default,默认给了一个添加该Shader的材质球 1Shader”U

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号