精彩编码 【进制转换】

精彩编码 【进制转换】

大家好,又见面了,我是全栈君,今天给大家准备了Idea注册码。

精彩编码
Description
如果没有阿拉伯数字,我们想得到怎样来表示数字
小明觉得一个方法,如下面的:
1 -> A
2 -> B
3 -> C
….
25 -> Y
26 -> Z
27 -> AA

28 -> AB
….

如今请你写一个程序完毕这个转换

Input
输入的第一个数为一个正整数T,表明接下来有T组数据。
每组数据为一个正整数n ( n <= 1000)

Output
对于每一个正整数n,输出他相应的字符串

Sample Input
3
1
10
27
Sample Output
A
J
AA

进制转换?

#include <stdio.h> 
#include <iostream> 
#include <math.h> 
#include <stdlib.h> 
#include <ctype.h> 
#include <algorithm> 
#include <vector> 
#include <string.h> 
#include <queue> 
#include <stack> 
#include <set> 
#include <sstream> 
#include <time.h> 
#include <utility> 
#include <malloc.h> 
#include <stdexcept> 
#include <iomanip> 
#include <iterator> 

using namespace std;

int main()
{
    int n,t;
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d",&n);
        if (n <= 26)
            printf("%c\n", 'A' + n - 1);
        else if (n <= 26 * 26 + 26)
        {
            n -= 27;
            int t = n / 26;
            printf("%c", 'A' + t);
            n = n % 26;
            printf("%c\n", 'A' + n);
        }
        else
        {
            n -= 27 + 26 * 26;
            printf("%c%c%c\n", 'A' + char(n / 26 / 26), 'A' + char((n / 26) % 26), 'A' + char(n % 26));
        }
    }
    return 0;
}

版权声明:转载请注明出处。

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/117143.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)


相关推荐

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号