杭州电 3711 Binary Number

杭州电 3711 Binary Number

大家好,又见面了,我是全栈君,今天给大家准备了Idea注册码。

Binary Number

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1287    Accepted Submission(s): 807

Problem Description
For 2 non-negative integers x and y, f(x, y) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1,f(0, 3)=2, f(5, 10)=4. Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find an integer a in A such that f(a, b) is minimized. If there are more than one such integer in set A, choose the smallest one.
 

Input
The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < m, n ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.
 

Output
For each test case you should output n lines, each of which contains the result for each query in a single line.
 

Sample Input
   
   
2 2 5 1 2 1 2 3 4 5 5 2 1000000 9999 1423 3421 0 13245 353

 

Sample Output
   
   
1 2 1 1 1 9999 0

AC代码例如以下:

#include <stdio.h>
int a[105];
int count(int x)
{
    int c = 0;
    for(;x;x>>=1) if(x&1) c++;
    return c;
}
int main()
{
    int b, i, j, n, m, k, min, t,cases;
    scanf("%d",&cases);
    while(cases--)
    {
        scanf("%d%d",&n,&m);
        for(i=0; i<n; i++) scanf("%d",&a[i]);
        for(i=0; i<m; i++)
        {
            scanf("%d",&b);
            min = count(b^a[0]);
            k = 0;
            for(j=1; j<n; j++)
            {
                t = count(b^a[j]);
                if(t<min||t==min&&a[j]<a[k])
                    { min = t;k = j;}
            }
            printf("%d\n",a[k]);
        }
    }
    return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/116703.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)


相关推荐

  • 多合一OEM Win7系统盘制作

    多合一OEM Win7系统盘制作准备工具:imageX工具imagex_16385_x86.rar(511.88KB,下载次数:718)2009-10-2211:13上传下载次数:718下载积分:PB币-1UltraISO(下载自己找吧)素材:原版Windows7Ultimate简体中文32位系统ISO一个(下载自己找吧)原版Windows7Ultim…

  • Linux 配置Java环境(图文详细)

    Linux 配置Java环境(图文详细)Linux配置Java环境1、查看系统是否有java环境2、卸载系统自带的jdk1.找到具体的jdk2.然后分别一个一个删除3.验证是否删除成功3、创建一个文件夹用于存放java的压缩包4、包下载好的jdk拖到java文件夹5、安装jdk6、配置环境变量7、让配置生效8、验证是否配置成功1、查看系统是否有java环境输入指令java-version回车即可如图表示Linux系统有自带的jdk,但是这并不是我们想要的,所以得卸载2、卸载系统自带的jdk1.找到具体的jdkrpm-qa

  • modelsim教程

    modelsim教程TheTutorialof Modelsim小狼@http://blog.csdn.net/xiaolangyangyang一、建立库vlibwork(库名)二、映射库到物理目录vmapwork(映射的逻辑名称)work(存放的物理地址)三、编译源代码vlog../src/MUX_4_8.vvlog../src/MU

    2022年10月22日
  • js数据转换为html,JavaScript怎么进行类型转换?「建议收藏」

    js数据转换为html,JavaScript怎么进行类型转换?「建议收藏」JavaScript怎么进行类型转换?下面本篇文章就来介绍一下使用javascript进行类型转换的方法,希望对大家有所帮助。JavaScript变量可以转换为新变量或其他数据类型,分为两种情况:● 隐性转换:通过JavaScript自身自动转换● 显性转换:通过使用JavaScript函数进行转换隐式转换JavaScript中有各种运算符和函数,它们自动将值转换为正确的类型,如Java…

  • USB3.0接口定义浅析

    USB3.0接口定义浅析https://www.bilibili.com/read/cv372294数码4-11357阅读14点赞3评论USB谁都见过、用过,作为世界上最常见的接口之一,USB早就走进了我们的生活。那么USB的接口定义是怎样的呢?让我来简单分析一下。因为USB3.0包括USB2.0的引脚,USB3.1和3.0引脚相同,所以本文以USB3.0(即USB3.1Gen1)为例来讲解。USB3.1一…

  • ps批量磨皮滤镜插件ArcSoft Portrait3+ 中文版瘦脸自动识别人脸win/mac支持2018「建议收藏」

    ps批量磨皮滤镜插件ArcSoft Portrait3+ 中文版瘦脸自动识别人脸win/mac支持2018「建议收藏」【系统支持】win系统(win10系统PS不能使用插件版,但是可以使用独立版)mac苹果系统只能使用插件版,不能使用独立版【支持PS】支持CS6-CC2108也可以独立使用苹果系统不能独立使用ArcSoftPortrait+是一款智能化的人像磨皮软件,采用世界上最尖端的人脸检测技术,能够自动检测人像脸部进行磨皮。ArcSoftPortrait+还支持批量处理功能,能同时处理上千张…

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号