杭州电 3711 Binary Number

杭州电 3711 Binary Number

大家好,又见面了,我是全栈君,今天给大家准备了Idea注册码。

Binary Number

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1287    Accepted Submission(s): 807

Problem Description
For 2 non-negative integers x and y, f(x, y) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1,f(0, 3)=2, f(5, 10)=4. Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find an integer a in A such that f(a, b) is minimized. If there are more than one such integer in set A, choose the smallest one.
 

Input
The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < m, n ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.
 

Output
For each test case you should output n lines, each of which contains the result for each query in a single line.
 

Sample Input
   
   
2 2 5 1 2 1 2 3 4 5 5 2 1000000 9999 1423 3421 0 13245 353

 

Sample Output
   
   
1 2 1 1 1 9999 0

AC代码例如以下:

#include <stdio.h>
int a[105];
int count(int x)
{
    int c = 0;
    for(;x;x>>=1) if(x&1) c++;
    return c;
}
int main()
{
    int b, i, j, n, m, k, min, t,cases;
    scanf("%d",&cases);
    while(cases--)
    {
        scanf("%d%d",&n,&m);
        for(i=0; i<n; i++) scanf("%d",&a[i]);
        for(i=0; i<m; i++)
        {
            scanf("%d",&b);
            min = count(b^a[0]);
            k = 0;
            for(j=1; j<n; j++)
            {
                t = count(b^a[j]);
                if(t<min||t==min&&a[j]<a[k])
                    { min = t;k = j;}
            }
            printf("%d\n",a[k]);
        }
    }
    return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/116703.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)


相关推荐

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号