HDU 3177 Crixalis's Equipment(贪婪)「建议收藏」

HDU 3177 Crixalis's Equipment(贪婪)

大家好,又见面了,我是全栈君。

主题链接:http://acm.hdu.edu.cn/showproblem.php?

pid=3177

Problem Description
HDU 3177 Crixalis's Equipment(贪婪)「建议收藏」Crixalis – Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he’s a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes.

Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it’s just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.

 
Input
The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next N lines contain N pairs of integers: Ai and Bi.

0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.

 
Output
For each case output “Yes” if Crixalis can move all his equipment into the new hole or else output “No”.
 
Sample Input
      
220 310 203 101 710 21 102 11

 
Sample Output
   
   
Yes No

 
Source

题意:

向一个容量为V的洞中放如入物品,每件物品有一个停放体积和一个可移动体积。问是否能放下全部的物品?

思路:—— 贪心

                                   停放体积         移动体积

                  第一件物品          a1             b1

  

                  第二件物品          a2             b2

如果这两件物品的移动体积都不大于洞的体积V

那么将单独比較两个物品的时候会发现:  a1+b2为先放第一件物品,后放第二件物品的最大瞬时体积

                                                        a2+b1为先放第二件物品。后放第一件物品的最大瞬时体积

那么我们就应该选择a1+b2和a2+b1中比較小的先放。

那么从2件物品。扩展到n件物品 如果n件物品的移动体积都不大于洞的体积V,

将N件物品依照a1+b2 < a2+b1进行排序,(事实上就是依照差值的大小)然后依次放入洞中。

PS: 

假设仅仅是单纯的依照Bi从大到小排序的话为WA;

看看这个案例就明确了。

21 2

8 18

1 20

Yes


代码例如以下:

#include <cstdio>
#include <algorithm>
#include <iostream>
#include <cstring>
using namespace std;
struct num
{
    int a, b;
} p[1017];
bool cmp(num A, num B)
{
    return A.b-A.a > B.b-B.a;
}
int main()
{
    int t;
    int v, n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&v,&n);
        for(int i = 0; i < n; i++)
        {
            scanf("%d %d",&p[i].a,&p[i].b);
        }
        sort(p,p+n,cmp);
        int i;
        for(i = 0; i < n; i++)
        {
            if(v >= p[i].b)
            {
                v-=p[i].a;
            }
            else
                break;
        }
        if(i == n)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/116646.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)


相关推荐

  • 如何将onedrive for business扩容为硬盘空间[通俗易懂]

    如何将onedrive for business扩容为硬盘空间[通俗易懂]首先,我们需要下载raidrive软件为我们扩容,那么我们已经申请好学生的5T的包了,若要看如何申请,请到https://graph.org/1%E5%88%86%E9%92%B1onedrive-5T%E8%B4%A6%E5%8F%B7-02-04去查看警告:本文作者只是从网上搜到了该文章,该文章并非本文作者所写,只是推荐而已,涉及版权问题本文作者不承担任何责任!下载raidrive的软件…

  • Shiro 框架简单介绍

    Shiro 框架简单介绍Shiro 框架简单介绍

  • 词法分析程序 LEX和VC6整合使用的一个简单例子

    词法分析的理论知识不少,包括了正规式、正规文法、它们之间的转换以及确定的有穷自动机和不确定的有穷自动机等等。。。要自己写一个词法分析器也不会很难,只要给出了最简的有穷自动机,就能很方便实现了,用if

    2021年12月25日
  • 华为模拟器——eNSP安装教程

    华为模拟器——eNSP安装教程华为模拟器——eNSP安装教程一、准备工作1.下载华为模拟器eNSP所需的软件安装包(图-1)图-12.上面三个必须软件安装无特殊要求下一步下一步进行安装即可,这里就不做过多讲解了3.下载华为模拟器eNSP安装包二、实施安装1.点击华为模拟器eNSP安装包进行安装(最好以右击以管理员身份运行)2.选择语言,选择中文简体(图-1)图-13.点击确认,下一步(图-2)图-24.选择我同意协议,点击下一步(图-3)图-35.安装位置(注.

    2022年10月14日
  • Android——NDK基础概念——ndk-build介绍

    Android——NDK基础概念——ndk-build介绍

  • Navicat连接sqlserver 2012踩坑

    Navicat连接sqlserver 2012踩坑Navicat连接sqlserver2012踩坑解决问题的办法来自于两个博客(搬运、记录)(1)[配置远账号和登录方式](https://blog.csdn.net/weixin_42241984/article/details/105432253)这里主要是账户的状态要注意2.[配置TCP的动态端口为1433]3.要注意的是在服务器里查看以下三个进程是否已经启动(除了sqlserveragent),以及修改后重启服务。…

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号