杭电 HDU ACM 1698 Just a Hook(线段树 区间更新 延迟标记)

杭电 HDU ACM 1698 Just a Hook(线段树 区间更新 延迟标记)

大家好,又见面了,我是全栈君。

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20889    Accepted Submission(s): 10445

Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.


杭电 HDU ACM 1698 Just a Hook(线段树 区间更新 延迟标记)

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.

The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.

For each silver stick, the value is 2.

For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.

You may consider the original hook is made up of cupreous sticks.

 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.

For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.

Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

 

Sample Input
       
       
1 10 2 1 5 2 5 9 3

 

Sample Output
       
       
Case 1: The total value of the hook is 24.




#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;
const int INF=100000;
int val[INF+1];
struct node//结构体表示结点
{
    int total;
    int left;
    int right;
    int mark;//是否上次被更新
} tree[INF<<2];

int create(int root,int left ,int right)//建树
{
    tree[root].left=left;
    tree[root].mark=0;
    tree[root].right=right;
    if(left==right)
        return tree[root].total=val[left];
    int a , b,middle=(left+right)>>1;
    a=create(root<<1,left,middle);
    b=create(root<<1|1,middle+1,right);
    return tree[root].total=a+b; //在回溯过程中给total赋值
}

void update_mark(int root)
{
    if(tree[root].mark)
    {//假设被延迟标记过而且此时须要在root的子孙中找须要更新的线段。无论找不找到既然研究到了
   // 此节点就要“落实”此节点total值 。并使延迟标记下移。
        tree[root].total=tree[root].mark*(tree[root].right-tree[root].left+1);
        if(tree[root].left!=tree[root].right)
            tree[root<<1].mark=tree[root<<1|1].mark=tree[root].mark;
        tree[root].mark=0;
    }
}

int calculate(int root,int left,int right)
{
    update_mark(root);//递归到每一个节点都要核实是否具有延迟标记
    if(tree[root].left>right||tree[root].right<left)
        return 0;
    if(left<=tree[root].left&&tree[root].right<=right)
        return tree[root].total;
    int a,b;
    a=calculate(root<<1,left,right);
    b=calculate(root<<1|1,left,right);
    return a+b;
}

int update(int root,int left,int right,int val)
{
    update_mark(root);
    if(tree[root].left>right||tree[root].right<left)
        return tree[root].total;
    if(tree[root].left>=left&&tree[root].right<=right)
    {
        tree[root].mark=val;
        return  tree[root].total=val*(tree[root].right-tree[root].left+1);
    }
    int a,b;
    a=update(root<<1,left,right,val);
    b=update(root<<1|1,left,right,val);
    return tree[root].total=a+b;
}

int main()
{
    int T;
    cin>>T;
    int c=0;
    while(T--)
    {
        int n,q,x,y,z;
        cin>>n;
        for(int i=1; i<=n; i++)
            val[i]=1;
        cin>>q;
        create(1,1,n);
        for(int i=0; i<q; i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            update(1,x,y,z);
        }
        printf("Case %d: The total value of the hook is %d.\n",++c,tree[1].total);
    }
    return  0;
}

 
版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/115657.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)
blank

相关推荐

  • QT QMap介绍与使用「建议收藏」

    QT QMap介绍与使用「建议收藏」Qt中的QMap介绍与使用,在坛子里逛了一圈,发现在使用QMap中,出现过很多的问题,Map是一个很有用的数据结构。它以“键-值”的形式保存数据。在使用的时候,通过提供字符标示(键)即可得到想要的数据。这个“数据”即可以是一个字符串,也可以是任意对象,当然也包括自己定义的类对象。说明:map是以值传递的形式保存数据的。1.基本应用下面以“键-值”都是QString的例子说明QMa

  • 手把手教你webpack3(9)File-Loader配置简述

    手把手教你webpack3(9)File-Loader配置简述

  • 一个导致502 bad gateway的原因[通俗易懂]

    一个导致502 bad gateway的原因[通俗易懂]最近一段时间系统经常出现502badgateway,一开始没在意,以为是偶发现象,后来越来越多改了nginx配置,问题没有解决观察日志,出现502badgateway时系统并没有出异常,猜测可能系统负载较大,把所有定时任务迁移到另外一台服务器,问题仍然没有解决最后通过Jconsole监控JVM发现每5分钟的第0秒,线程和内存曲线都会降为0,这个时候正好是出

  • 机器学习面试题60~100「建议收藏」

    机器学习面试题60~100「建议收藏」61.说说梯度下降法  @LeftNotEasy,本题解析来源:http://www.cnblogs.com/LeftNotEasy/archive/2010/12/05/mathmatic_in_machine_learning_1_regression_and_gradient_descent.html  下面是一个典型的机器学习的过程,首先给出一个输入数据,我们的算法会通过一系列的过程得到一…

  • C语言基础知识入门(大全)「建议收藏」

    C语言基础知识入门(大全)「建议收藏」一.C语言入门C语言一经出现就以其功能丰富、表达能力强、灵活方便、应用面广等特点迅速在全世界普及和推广。C语言不但执行效率高而且可移植性好,可以用来开发应用软件、驱动、操作系统等。C语言也是其它众多高级语言的鼻祖语言,所以说学习C语言是进入编程世界的必修课!更多详细进阶教程等你领取!可以关注公众号“C和C加加”回复“ZXC”即可免费获取!二.C语言的具体结构简单来说,一个C程序就是由若干头文件和函数组成。 #include<stdio.h>就是一条预处理命..

  • SpringBoot热部署(IDEA 2109 )「建议收藏」

    SpringBoot热部署(IDEA 2109 )「建议收藏」SpringBoot热部署(IDEA 2109 )

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号