#include<algorithm>
lower_bound(int* first,int* last,val);
函数lower_bound()在first和last中的前闭后开区间,进行二分查找。返回从first开始的第一个大于或等于val的元素的地址。如果所有元素都小于val,则返回last的地址。注意:数组必须是排好序的数组。
所以通常用法是:
int a[8]={4,10,11,30,69,70,96,100};
int pos;
pos=lower_bound(a,a+8,11)-a;
这样pos就是第一个大于或等于11的元素的下标。运算结果为pos=2;
如果不存在这样的元素:
pos = lower_bound( a, a + 8, 111) - number, pos = 8;
即number数组的下标为8的位置(但下标上限为7,所以返回最后一个元素的下一个元素)
大理石在哪儿(Where is the Marble?,Uva 10474)
现有N个大理石,每个大理石上写了一个非负整数。首先把各数从小到大排序,然后回 答Q个问题。每个问题问是否有一个大理石写着某个整数x,如果是,还要回答哪个大理石上 写着x。排序后的大理石从左到右编号为1~N。(在样例中,为了节约篇幅,所有大理石上 的数合并到一行,所有问题也合并到一行。)
样例输入:
4 1
2 3 5 1
5
5 2
1 3 3 3 1
2 3
样例输出:
CASE #1:
5 found at 4
CASE #2:
2 not found
3 found at 3
【分析】
题目意思已经很清楚了:先排序,再查找。使用algorithm头文件中的sort和lower_bound 很容易完成这两项操作,代码如下:
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
const int maxn = 10000;
int main()
{
int n, m, x,ase = 0;
int a[maxn];
while(scanf("%d%d",&n,&m)==2&&n)
{
for(int i=0;i<n;i++){
cin>>a[i];
}
sort(a,a+n); printf("CASE# %d:\n",++ase);
while(m--)
{
cin >> x;
int p=lower_bound(a+1,a+n,x)-a;//早已排数组中寻找x
if(a[p]==x)
printf("%d found at %d\n",x,p+1);
else
printf("%d not found\n",x);
}
}
return 0;
}
发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/114898.html原文链接:https://javaforall.cn
【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛
【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...