hd2616

hd2616

There is a mountain near yifenfei’s hometown. On the mountain lived a big monster. As a hero in hometown, yifenfei wants to kill it.
Now we know yifenfei have n spells, and the monster have m HP, when HP <= 0 meaning monster be killed. Yifenfei’s spells have different effect if used in different time. now tell you each spells’s effects , expressed (A ,M). A show the spell can cost A HP to monster in the common time. M show that when the monster’s HP <= M, using this spell can get double effect.
Input
The input contains multiple test cases.
Each test case include, first two integers n, m (2<n<10, 1<m<10^7), express how many spells yifenfei has.
Next n line , each line express one spell. (Ai, Mi).(0<Ai,Mi<=m).
Output
For each test case output one integer that how many spells yifenfei should use at least. If yifenfei can not kill the monster output -1.
Sample Input
3 100
10 20
45 89
5 40

3 100
10 20
45 90
5 40
3 100
10 20
45 84
5 40
Sample Output
3
2
-1

大概就是n表示的三次魔法,m表示的是hp值然后,下面三个是每个法术的普通伤害和低于他规定的值后翻倍;
用深度优先搜索暴力解题,其实dfs本质还是跟递归有关,还是不能学的僵化了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string>
using namespace std;
int used[100];//标志变量
int a[100],b[100];//存储两个数
int ans;//判断变量
int cut=0;
int n, m;
void dfs(int bllod,int cut)
{
	if(cut>n)
		return ;
	if(bllod<=0&&cut<ans)
	{
		ans=cut; 
		return ;
	} 
	for(int i=0;i<n;i++){
		if(!used[i])
		{
			used[i]=1;
			if(bllod<=b[i])
				dfs(bllod-2*a[i],cut+1);
			else
				dfs(bllod-a[i],cut+1);
			used[i]=0;  
		}
	}
}
int main(){
	
	while(cin>>n>>m)
	{
		
		for(int i=0;i<n;i++)
		{
			cin >> a[i] >>b[i];
		} 
		memset(used,0,sizeof(used));
		ans=1314;
		dfs(m,cut);  
		if(ans!=1314)
			cout<<ans<<endl;
			else cout<<-1<<endl; 
			cut=0;
	 } 
	return 0;
} 
版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/114896.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)


相关推荐

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号