POJ 1502 MPI Maelstrom「建议收藏」

POJ 1502 MPI Maelstrom「建议收藏」POJ 1502 MPI Maelstrom

大家好,又见面了,我是你们的朋友全栈君。

MPI Maelstrom
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 3896   Accepted: 2330

Description

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee’s research advisor, Jack Swigert, has asked her to benchmark the new system. 

“Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,” Valentine told Swigert. “Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.” 

“How is Apollo’s port of the Message Passing Interface (MPI) working out?” Swigert asked. 

“Not so well,” Valentine replied. “To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.” 

“Is there anything you can do to fix that?” 

“Yes,” smiled Valentine. “There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.” 

“Ah, so you can do the broadcast as a binary tree!” 

“Not really a binary tree — there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don’t necessarily arrive at the destinations at the same time — there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.”

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100. 

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j. 

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied. 

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35

Source

 

Floyd:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>

using namespace std;

const int N=110;
const int INF=0x3f3f3f3f;

int map[N][N],dis[N],vis[N];
int n;

int main(){

    //freopen("input.txt","r",stdin);

    char str[20];
    while(~scanf("%d",&n)){
        int i,j,k;
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
                map[i][j]=(i==j?0:INF);
        for(i=2;i<=n;i++)
            for(j=1;j<i;j++){
                scanf("%s",str);
                if(str[0]=='x')
                    map[i][j]=map[j][i]=INF;
                else
                    map[i][j]=map[j][i]=atoi(str);
            }
        for(k=1;k<=n;k++)
            for(i=1;i<=n;i++)
                for(j=1;j<=n;j++)
                    if(map[i][j]>map[i][k]+map[k][j])
                        map[i][j]=map[i][k]+map[k][j];
        int ans=-INF;
        for(int i=2;i<=n;i++)
            if(ans<map[1][i])
                ans=map[1][i];
        printf("%d\n",ans);
    }
    return 0;
}

 

 

Dijkstra:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>

using namespace std;

const int N=110;
const int INF=0x3f3f3f3f;

int map[N][N],dis[N],vis[N];
int n;

void Dijkstra(int src){
    int i;
    for(i=1;i<=n;i++){
        dis[i]=map[src][i];
        vis[i]=0;
    }
    dis[src]=0;
    vis[src]=1;
    int j,k,tmp;
    for(i=1;i<n;i++){
        tmp=INF;
        for(j=1;j<=n;j++)
            if(!vis[j] && tmp>dis[j]){
                tmp=dis[j];
                k=j;
            }
        if(tmp==INF)
            break;
        vis[k]=1;
        for(j=1;j<=n;j++)
            if(!vis[j] && dis[j]>dis[k]+map[k][j])
                dis[j]=dis[k]+map[k][j];
    }
}

int main(){

    //freopen("input.txt","r",stdin);

    char str[20];
    while(~scanf("%d",&n)){
        int i,j;
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
                map[i][j]=(i==j?0:INF);
        for(i=2;i<=n;i++)
            for(j=1;j<i;j++){
                scanf("%s",str);
                if(str[0]!='x')
                    map[i][j]=map[j][i]=atoi(str);
            }
        Dijkstra(1);
        int ans=-INF;
        for(i=2;i<=n;i++)
            if(ans<dis[i])
                ans=dis[i];
        printf("%d\n",ans);
    }
    return 0;
}

 

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/107094.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)


相关推荐

  • 开源 微商分销系统 php,[PHP程序] 微商新零售分销平台源码Thinkphp内核 产品营销推广神器…

    开源 微商分销系统 php,[PHP程序] 微商新零售分销平台源码Thinkphp内核 产品营销推广神器…源码介绍一个新零售的派单工具,有了平台,会让客户主动加你买货,100%成交,还会积极帮你转介绍,让你不仅仅获得派单,还能建立自己的商友圈,积累强大的人脉。平台的机制中一共分为13个商友星级,从一星到十三星,每升一星就会获得大量的平台派单,升到13星一共可获得百万笔零售订单。平台没有行业限制,无论你是微商,电商还是实体,无论你是卖衣服、化妆品还是食品,都可以使用平台。同行可以合作,异业可以联盟,不用…

  • Unity 点乘和叉乘的原理和使用

    Unity 点乘和叉乘的原理和使用Unity当中经常会用到向量的运算来计算目标的方位,朝向,角度等相关数据,下面咱们来通过实例学习下Unity当中最常用的点乘和叉乘的使用。点乘 (又称”点积”,”数量积”,”内积”)(DotProduct,用*)定义:a·b=|a|·|b|cos【注:粗体小写字母表示向量,表示向量a,b的夹角,取值范围为[0,180]】几何意义:是一条边向另一条边的投影乘以另一条边的长度.

    2022年10月23日
  • pycharm支持32位版本_pycharm下载哪个版本

    pycharm支持32位版本_pycharm下载哪个版本pycharm32位下载的同学们,官网地址在此。各种历史版本,亲测有效。OtherVersions-PyCharm(jetbrains.com)

  • maven打包时打包指定的lib文件夹

    maven打包时打包指定的lib文件夹今天在打包自己的springboot项目时遇到了问题,报找不到类和符号。因为我有些依赖是放在项目lib文件夹中,那么打包的时候要连把它一起打包。修改pom.xml,添加一下内容:<build><plugins><plugin><groupId>or…

  • fferrone_png转换svg

    fferrone_png转换svgffmpeg-vcodecrawvideo-frawvideo-pix_fmtbgr32-s1792x2176-i~/Downloads/dumpdata/dump_src_44_0_f2_1792x2176.raw-fimage2-vcodec pngscreenshot1.png颜色不对一般是RGB的值有问题 PIX_FMT_RGB24改成PIX_FM

  • 字符串匹配——枚举法[通俗易懂]

    字符串匹配——枚举法[通俗易懂]字符串匹配——枚举法给定主串T和模式串P,返回P在T中首次出现的位置,如果P不存在于T中,返回-1。这样的问题就是字符串匹配问题,这里先给出枚举法的思想。设主串T的长度为n,模式串P的长度为m。主串从0到n-m,每次选取连续的m个字符,跟模式串P的m个字符进行一一比较。伪代码BruteForce(T,P)01fors<-0ton-m02j<-003//check

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号